source: npl/kernel/drv_dahdi/drv_dahdi.SlackBuild.disabled

Last change on this file was 1ebb340, checked in by Edwin Eefting <edwin@datux.nl>, 4 years ago

kernel 5.10

  • Property mode set to 100755
File size: 3.3 KB
Line 
1#!/bin/bash
2#Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild
3#Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
4#Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
5##################################### Build dependency info:
6
7#Strict build-dependencies
8#Our package will be automaticly rebuilded if there is a major change in a DEP package.
9#(this is recommended for most dependencys)
10#DEP:linux
11#DEP:linux_src
12#DEP:linux_headers
13#DEP:linux
14##DEP:libpri
15##DEP:openldap
16
17#Loose build-dependencies
18#The package will be installed in the buildroot during buidling, but no automatic rebuild will occur.
19#(not recommended)
20##DEP:doxygen
21
22
23#######Essential package info.
24#Change these if autodetection fails.
25
26#Name of the Syn-3 package that we are going to create
27NAME=`basename $0|sed 's/.SlackBuild//'`
28
29#Version of the sourcefiles
30#VER="2.11.1"
31VER="3.1.0"
32
33#Archive of the sourcefiles to unpack
34#SRC_ARC="dahdi-linux-$VER.tar.gz"
35SRC_ARC="dahdi-linux-complete-$VER+$VER.tar.gz"
36
37
38
39#Architecture that the created binaries run on.
40#Use noarch for scripts.
41ARCH=`uname -m`
42
43########Build and create the pacakge.
44#Uncomment the stuff that you dont want or need
45
46#Unpack source
47#(uncomment if not needed)
48syn3_unpack $SRC_ARC || exit 1
49
50#Directory where the sourcefiles are unpacked.
51#(you might have to adjust this if autodetection fails)
52SRC_DIR=`ls -c|head -1`
53
54#apply patches
55#patch -p1 -d $SRC_DIR < 0001-xpp-move-command_timer-functions-to-xbus-core.patch || exit 1
56#patch -p1 -d $SRC_DIR < 0002-fix-building-with-4.15-init_timer-setup_timer.patch || exit 1
57#patch -p1 -d $SRC_DIR/linux < 0001-xpp-move-command_timer-functions-to-xbus-core.patch || exit 1
58#patch -p1 -d $SRC_DIR/linux < 0002-fix-building-with-4.15-init_timer-setup_timer.patch || exit 1
59#patch -p1 -d $SRC_DIR/linux < p.patch || exit 1
60sed 's/DAHDI_BUILD_ALL:=m/DAHDI_BUILD_ALL:=n/' -i $SRC_DIR/linux/Makefile  || exit 1
61
62#AUTOMAKE: Configure
63pushd /tmp/build/$SRC_DIR || exit 1
64#./configure --prefix=/usr || exit 1
65#exit 1
66#AUTOMAKE: Compile
67MAKE_OPTS="-j1"
68MODULES_EXTRA=dahdi_dummy make $MAKE_OPTS || exit 1
69
70#AUTOMAKE: Test (optional)
71#if grep ^check: Makefile; then
72#       make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1
73#       make $MAKE_OPTS check || exit 1
74#elif grep ^test: Makefile; then
75#       make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1
76#       make $MAKE_OPTS test || exit 1
77#fi
78
79#AUTOMAKE: Install
80mkdir -p /tmp/pkg &>/dev/null
81MODULES_EXTRA=dahdi_dummy make pkgconfigdir=/usr/lib/pkgconfig install_prefix=/tmp/pkg DESTDIR=/tmp/pkg INSTALL_ROOT=/tmp/pkg install_root=/tmp/pkg $MAKE_OPTS install >/dev/null || exit 1
82popd
83
84#chown -R nobody:nogroup /tmp/pkg/dev/dahdi || exit 1
85
86mkdir -p /tmp/pkg/etc/boot.d || exit 1
87cp dahdi /tmp/pkg/etc/boot.d || exit 1
88chmod +x /tmp/pkg/etc/boot.d/* || exit 1
89
90#somehow these rules give errors
91rm -rf /tmp/pkg/etc/udev
92
93
94mkdir -p /tmp/pkg/etc/postinst.d || exit 1
95cp post.dahdi /tmp/pkg/etc/postinst.d || exit 1
96chmod +x /tmp/pkg/etc/postinst.d/* || exit 1
97
98
99#strip bins and other stuff
100syn3_strip /tmp/pkg || exit 1
101
102#move development stuff and create seperate development package
103syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
104syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
105
106#make main package
107syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
108
109
Note: See TracBrowser for help on using the repository browser.