source: npl/kernel/drv_dahdi/drv_dahdi.SlackBuild @ f6630dd

Last change on this file since f6630dd was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 2.8 KB
Line 
1#!/bin/bash
2#Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild
3#Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
4#Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
5##################################### Build dependency info:
6
7#Strict build-dependencies
8#Our package will be automaticly rebuilded if there is a major change in a DEP package.
9#(this is recommended for most dependencys)
10#DEP:linux
11#DEP:linux_src
12#DEP:linux_headers
13#DEP:linux
14##DEP:libpri
15##DEP:openldap
16
17#Loose build-dependencies
18#The package will be installed in the buildroot during buidling, but no automatic rebuild will occur.
19#(not recommended)
20##DEP:doxygen
21
22
23#######Essential package info.
24#Change these if autodetection fails.
25
26#Name of the Syn-3 package that we are going to create
27NAME=`basename $0|sed 's/.SlackBuild//'`
28
29#Version of the sourcefiles
30VER="2.11.1"
31
32#Archive of the sourcefiles to unpack
33SRC_ARC="dahdi-linux-$VER.tar.gz"
34
35
36
37#Architecture that the created binaries run on.
38#Use noarch for scripts.
39ARCH=`uname -m`
40
41########Build and create the pacakge.
42#Uncomment the stuff that you dont want or need
43
44#Unpack source
45#(uncomment if not needed)
46syn3_unpack $SRC_ARC || exit 1
47
48#Directory where the sourcefiles are unpacked.
49#(you might have to adjust this if autodetection fails)
50SRC_DIR=`ls -c|head -1`
51
52#apply patches
53#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
54
55
56#AUTOMAKE: Configure
57pushd /tmp/build/$SRC_DIR || exit 1
58#./configure --prefix=/usr || exit 1
59#exit 1
60#AUTOMAKE: Compile
61MAKE_OPTS="-j1"
62make $MAKE_OPTS || exit 1
63
64#AUTOMAKE: Test (optional)
65#if grep ^check: Makefile; then
66#       make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1
67#       make $MAKE_OPTS check || exit 1
68#elif grep ^test: Makefile; then
69#       make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1
70#       make $MAKE_OPTS test || exit 1
71#fi
72
73#AUTOMAKE: Install
74mkdir -p /tmp/pkg &>/dev/null
75make pkgconfigdir=/usr/lib/pkgconfig install_prefix=/tmp/pkg DESTDIR=/tmp/pkg INSTALL_ROOT=/tmp/pkg install_root=/tmp/pkg $MAKE_OPTS install >/dev/null || exit 1
76popd
77
78#chown -R nobody:nogroup /tmp/pkg/dev/dahdi || exit 1
79
80mkdir -p /tmp/pkg/etc/boot.d || exit 1
81cp dahdi /tmp/pkg/etc/boot.d || exit 1
82chmod +x /tmp/pkg/etc/boot.d/* || exit 1
83
84#somehow these rules give errors
85rm -rf /tmp/pkg/etc/udev
86
87
88mkdir -p /tmp/pkg/etc/postinst.d || exit 1
89cp post.dahdi /tmp/pkg/etc/postinst.d || exit 1
90chmod +x /tmp/pkg/etc/postinst.d/* || exit 1
91
92
93#strip bins and other stuff
94syn3_strip /tmp/pkg || exit 1
95
96#move development stuff and create seperate development package
97syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
98syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
99
100#make main package
101syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
102
103
Note: See TracBrowser for help on using the repository browser.