source: npl/kernel/drv_i40e/drv_i40e.SlackBuild @ 1bce4e1

Last change on this file since 1bce4e1 was 1bce4e1, checked in by Edwin Eefting <edwin@datux.nl>, 4 years ago

kernel 4.14.206 and i40e driver

  • Property mode set to 100755
File size: 580 bytes
RevLine 
[1bce4e1]1#!/bin/sh
2#DEP:linux_src
3#DEP:linux_headers
4#DEP:linux
5
6CWD=`pwd`
7TMP=/$CWD/tmp
8PKG=/tmp/pkg
9mkdir -p $PKG
10mkdir $TMP
11
12VERSION=2.16.11
13ARCH=${ARCH:-i486}
14
15cd $TMP
16tar -xzf $CWD/i40e-$VERSION.tar.gz || exit 1
17cd i40e-$VERSION/src || exit 1
18
19make || exit 1
20#make INSTALL_MOD_PATH=/tmp/pkg install || exit 1
21mkdir -p /tmp/pkg/lib/modules/`uname -r`/extra || exit 1
22cp *ko /tmp/pkg/lib/modules/`uname -r`/extra || exit 1
23
24#package maken
25cd $PKG
26NAME=`echo $0|cut -f2 -d'.'`
27makepkg -l y -c n $CWD/$NAME.pkg > /dev/null &&
28echo $VERSION > $CWD/$NAME.version &&
29arch > $CWD/$NAME.arch
Note: See TracBrowser for help on using the repository browser.