Last change
on this file since 1bce4e1 was
1bce4e1,
checked in by Edwin Eefting <edwin@datux.nl>, 4 years ago
|
kernel 4.14.206 and i40e driver
|
-
Property mode set to
100755
|
File size:
580 bytes
|
Rev | Line | |
---|
[1bce4e1] | 1 | #!/bin/sh |
---|
| 2 | #DEP:linux_src |
---|
| 3 | #DEP:linux_headers |
---|
| 4 | #DEP:linux |
---|
| 5 | |
---|
| 6 | CWD=`pwd` |
---|
| 7 | TMP=/$CWD/tmp |
---|
| 8 | PKG=/tmp/pkg |
---|
| 9 | mkdir -p $PKG |
---|
| 10 | mkdir $TMP |
---|
| 11 | |
---|
| 12 | VERSION=2.16.11 |
---|
| 13 | ARCH=${ARCH:-i486} |
---|
| 14 | |
---|
| 15 | cd $TMP |
---|
| 16 | tar -xzf $CWD/i40e-$VERSION.tar.gz || exit 1 |
---|
| 17 | cd i40e-$VERSION/src || exit 1 |
---|
| 18 | |
---|
| 19 | make || exit 1 |
---|
| 20 | #make INSTALL_MOD_PATH=/tmp/pkg install || exit 1 |
---|
| 21 | mkdir -p /tmp/pkg/lib/modules/`uname -r`/extra || exit 1 |
---|
| 22 | cp *ko /tmp/pkg/lib/modules/`uname -r`/extra || exit 1 |
---|
| 23 | |
---|
| 24 | #package maken |
---|
| 25 | cd $PKG |
---|
| 26 | NAME=`echo $0|cut -f2 -d'.'` |
---|
| 27 | makepkg -l y -c n $CWD/$NAME.pkg > /dev/null && |
---|
| 28 | echo $VERSION > $CWD/$NAME.version && |
---|
| 29 | arch > $CWD/$NAME.arch |
---|
Note: See
TracBrowser
for help on using the repository browser.