source: npl/kernel/drv_mISDN/drv_mISDN.SlackBuild.dis @ b4abfab

perl-5.22
Last change on this file since b4abfab was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 980 bytes
RevLine 
[c5c522c]1#!/bin/bash
2#DEP:linux_src
3#DEP:linux
4
5NAME=drv_mISDN
6CWD=`pwd`
7VER=1_1_9_2
8PKGTMP=/tmp/pkgtmp
9
10#mkdir -p $PKGTMP/usr/lib/asterisk/modules || exit 1
11#mkdir -p $PKGTMP/etc/asterisk || exit 1
12mkdir -p $PKGTMP/etc/boot.d || exit 1
13tar -xzf mISDN-$VER.tar.gz || exit 1
14
15cp misdn.boot.d $PKGTMP/etc/boot.d/misdn || exit 1
16
17cd mISDN-$VER || exit 1
18make -j1 force || exit 1
19#HACK: omdat dit in het buildscript anders word aangeroepen.
20#depmod gaat niet goed ivm verschil tussen buildroot kernel versie en echte
21rm `which depmod`
22make -j1 INSTALL_PREFIX=$PKGTMP install || exit 1
23
24pushd $PKGTMP/lib/modules/`uname -r`/extra/ || exit 1
25#strippen, omdat driver anders vele megabytes word!
26strip --strip-unneeded * || exit 1
27popd
28
29mkdir -p $PKGTMP/etc/postinst.d
30cp $CWD/post.mISDN $PKGTMP/etc/postinst.d || exit 1
31chmod +x $PKGTMP/etc/postinst.d/* || exit 1
32
33cd "$PKGTMP" || exit 1
34makepkg -l n -c n $CWD/$NAME.pkg > /dev/null &&
35echo $VER > $CWD/$NAME.version &&
36arch > $CWD/$NAME.arch
37
Note: See TracBrowser for help on using the repository browser.