perl-5.22
Last change
on this file since b4abfab was
c5c522c,
checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago
|
initial commit, transferred from cleaned syn3 svn tree
|
-
Property mode set to
100755
|
File size:
980 bytes
|
Rev | Line | |
---|
[c5c522c] | 1 | #!/bin/bash |
---|
| 2 | #DEP:linux_src |
---|
| 3 | #DEP:linux |
---|
| 4 | |
---|
| 5 | NAME=drv_mISDN |
---|
| 6 | CWD=`pwd` |
---|
| 7 | VER=1_1_9_2 |
---|
| 8 | PKGTMP=/tmp/pkgtmp |
---|
| 9 | |
---|
| 10 | #mkdir -p $PKGTMP/usr/lib/asterisk/modules || exit 1 |
---|
| 11 | #mkdir -p $PKGTMP/etc/asterisk || exit 1 |
---|
| 12 | mkdir -p $PKGTMP/etc/boot.d || exit 1 |
---|
| 13 | tar -xzf mISDN-$VER.tar.gz || exit 1 |
---|
| 14 | |
---|
| 15 | cp misdn.boot.d $PKGTMP/etc/boot.d/misdn || exit 1 |
---|
| 16 | |
---|
| 17 | cd mISDN-$VER || exit 1 |
---|
| 18 | make -j1 force || exit 1 |
---|
| 19 | #HACK: omdat dit in het buildscript anders word aangeroepen. |
---|
| 20 | #depmod gaat niet goed ivm verschil tussen buildroot kernel versie en echte |
---|
| 21 | rm `which depmod` |
---|
| 22 | make -j1 INSTALL_PREFIX=$PKGTMP install || exit 1 |
---|
| 23 | |
---|
| 24 | pushd $PKGTMP/lib/modules/`uname -r`/extra/ || exit 1 |
---|
| 25 | #strippen, omdat driver anders vele megabytes word! |
---|
| 26 | strip --strip-unneeded * || exit 1 |
---|
| 27 | popd |
---|
| 28 | |
---|
| 29 | mkdir -p $PKGTMP/etc/postinst.d |
---|
| 30 | cp $CWD/post.mISDN $PKGTMP/etc/postinst.d || exit 1 |
---|
| 31 | chmod +x $PKGTMP/etc/postinst.d/* || exit 1 |
---|
| 32 | |
---|
| 33 | cd "$PKGTMP" || exit 1 |
---|
| 34 | makepkg -l n -c n $CWD/$NAME.pkg > /dev/null && |
---|
| 35 | echo $VER > $CWD/$NAME.version && |
---|
| 36 | arch > $CWD/$NAME.arch |
---|
| 37 | |
---|
Note: See
TracBrowser
for help on using the repository browser.