source: npl/kernel/drv_pf_ring/drv_pf_ring.SlackBuild @ cc2b9e2

ntopperl-5.22
Last change on this file since cc2b9e2 was cc2b9e2, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

added ntopng and dependencies

  • Property mode set to 100755
File size: 1.5 KB
Line 
1#!/bin/bash
2
3##NEED:...
4#DEP:linux_src
5#DEP:linux
6
7#######Essential package info.
8#Change these if autodetection fails.
9
10#Name of the Syn-3 package that we are going to create
11NAME=`basename $0|sed 's/.SlackBuild//'`
12
13#Archive of the sourcefiles to unpack
14SRC_ARC=`ls *.tar.* *.zip 2>/dev/null`
15
16#Version of the sourcefiles
17VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g' | sed 's/\.zip$//g'`
18
19#Architecture that the created binaries run on.
20#Use noarch for scripts.
21ARCH=`uname -m`
22
23#from this point on, exit on errors:
24set -e
25
26########Build and create the pacakge.
27#Uncomment the stuff that you dont want or need
28
29#Unpack source
30#(uncomment if not needed)
31syn3_unpack $SRC_ARC
32
33#Directory where the sourcefiles are unpacked.
34#(you might have to adjust this if autodetection fails)
35SRC_DIR=`ls -c|head -1`
36
37#apply patches
38#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
39
40pushd $SRC_DIR
41
42
43#AUTOMAKE: Compile
44cd kernel
45make -j1 || exit 1
46make pkgconfigdir=/usr/lib/pkgconfig install_prefix=/tmp/pkg DESTDIR=/tmp/pkg INSTALL_ROOT=/tmp/pkg install_root=/tmp/pkg -j1 install || exit 1
47
48cd ../userland
49make -j1 || exit 1
50make pkgconfigdir=/usr/lib/pkgconfig install_prefix=/tmp/pkg DESTDIR=/tmp/pkg INSTALL_ROOT=/tmp/pkg install_root=/tmp/pkg -j1 install || exit 1
51
52popd
53
54#strip bins and other stuff
55syn3_strip /tmp/pkg || exit 1
56
57#move development stuff and create seperate development package
58syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
59syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
60
61#make main package
62syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
63
64
65
Note: See TracBrowser for help on using the repository browser.