source: npl/kernel/linux/linux.SlackBuild @ 62266ed

Last change on this file since 62266ed was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 1.1 KB
Line 
1#!/bin/bash
2#DEP:linux_src
3#NEED:bc
4
5NAME=linux
6CWD=`pwd`
7PKGTMP=/tmp/pkgtmp
8
9mkdir -p $PKGTMP &>/dev/null
10
11cd /usr/src/linux || exit 1
12
13
14make INSTALL_MOD_STRIP=1 bzImage || exit 1
15make INSTALL_MOD_STRIP=1 modules  || exit 1
16make INSTALL_MOD_STRIP=1 INSTALL_MOD_PATH=$PKGTMP modules_install || exit 1
17
18#bepaal versie nummer
19VER=`ls $PKGTMP/lib/modules | tail -1` || exit 1
20
21
22mkdir $PKGTMP/boot
23cp `find .|grep '/bzImage$'| head -1` $PKGTMP/boot/bzImage.test || exit 1
24
25#nodig voor depmod.pl van busybox:
26#cp `find .|grep '/System.map$'| head -1` $PKGTMP/boot/System.map || exit 1
27
28
29#Als je externe modules bakt, bv mISDN, dan ben je Module.symvers nodig.
30mkdir -p $PKGTMP`echo /usr/src/linux-*` || exit 1
31cp Module.symvers $PKGTMP`echo /usr/src/linux-*` || exit 1
32
33#nodig voor onderandere de drv_cciss driver
34cp Module.symvers $PKGTMP/lib/modules/$VER || exit 1
35
36mkdir -p $PKGTMP/etc/postinst.d
37cp $CWD/post.linux $PKGTMP/etc/postinst.d || exit 1
38chmod +x $PKGTMP/etc/postinst.d/* || exit 1
39
40
41echo "* kernel package maken"
42cd "$PKGTMP" || exit 1
43makepkg -l y -c n $CWD/$NAME.pkg > /dev/null &&
44echo $VER > $CWD/$NAME.version &&
45arch > $CWD/$NAME.arch
Note: See TracBrowser for help on using the repository browser.