source: npl/kernel/linux_embedded/linux_embedded.SlackBuild @ 26ffad7

Last change on this file since 26ffad7 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 1.2 KB
Line 
1#!/bin/bash
2#DEP:linux_src_embedded
3NAME=linux_embedded
4CWD=`pwd`
5PKGTMP=/tmp/pkgtmp
6
7mkdir -p $PKGTMP &>/dev/null
8
9cd /usr/src/linux || exit 1
10make bzImage || exit 1
11make modules  || exit 1
12make INSTALL_MOD_PATH=$PKGTMP modules_install || exit 1
13
14#bepaal versie nummer
15VER=`ls $PKGTMP/lib/modules | tail -1` || exit 1
16
17
18#gebeurd nu in openswan.SlackBuild
19#cp -a /lib/modules/$VER/kernel/ipsec.o  $CWD/pkg/lib/modules/$VER/kernel || exit 1
20
21mkdir $PKGTMP/boot
22cp `find .|grep '/bzImage$'| head -1` $PKGTMP/boot/bzImage.test || exit 1
23
24#nodig voor depmod.pl van busybox:
25cp `find .|grep '/System.map$'| head -1` $PKGTMP/boot/System.map || exit 1
26
27#EDWIN: geen symlinks meer, dit maakt alles ubercomplex namelijk
28#cd $PKGTMP/boot
29#ln -s bzImage-$VER bzImage.test || exit 1
30#ln -s System.map-$VER System.map.test || exit 1
31
32#Als je externe modules bakt, bv mISDN, dan ben je Module.symvers nodig.
33mkdir -p $PKGTMP`echo /usr/src/linux-*` || exit 1
34cp Module.symvers $PKGTMP`echo /usr/src/linux-*` || exit 1
35
36#nodig voor onderandere de drv_cciss driver
37cp Module.symvers $PKGTMP/lib/modules/$VER || exit 1
38
39
40echo "* kernel package maken"
41cd "$PKGTMP" || exit 1
42makepkg -l y -c n $CWD/$NAME.pkg > /dev/null &&
43echo $VER > $CWD/$NAME.version &&
44arch > $CWD/$NAME.arch
Note: See TracBrowser for help on using the repository browser.