[c5c522c] | 1 | #!/bin/bash |
---|
| 2 | #Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild |
---|
| 3 | #Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven. |
---|
| 4 | #Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden. |
---|
| 5 | ##################################### Build dependency info: |
---|
| 6 | |
---|
| 7 | #Strict build-dependencies. |
---|
| 8 | #Only use when really neccesary, this will rebuild our package if the dependencie has changed: |
---|
| 9 | #DEP:linux |
---|
| 10 | #DEP:linux_src |
---|
| 11 | |
---|
| 12 | #Loose build-dependencies. |
---|
| 13 | #Use this to specify the packages that are required to build our package: |
---|
| 14 | ##NEED:libcairo |
---|
| 15 | ##NEED:glib |
---|
| 16 | ##NEED:gtk+ |
---|
| 17 | ##NEED:glib2 |
---|
| 18 | ##NEED:gtk+2 |
---|
| 19 | ##NEED:xorg_lib |
---|
| 20 | ##NEED:xorg_proto |
---|
| 21 | |
---|
| 22 | #######Essential package info. |
---|
| 23 | #Change these if autodetection fails. |
---|
| 24 | |
---|
| 25 | #Name of the Syn-3 package that we are going to create |
---|
| 26 | NAME=`basename $0|sed 's/.SlackBuild//'` |
---|
| 27 | |
---|
| 28 | #Archive of the sourcefiles to unpack |
---|
| 29 | SRC_ARC=`ls *.tar.*` |
---|
| 30 | |
---|
| 31 | #Version of the sourcefiles |
---|
| 32 | VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g'` |
---|
| 33 | |
---|
| 34 | #Directory of the sourcefiles to build (after optional unpacking) |
---|
| 35 | SRC_DIR=`echo $SRC_ARC| sed 's/\.tar\..*$//g'` |
---|
| 36 | |
---|
| 37 | #Architecture that the created binaries run on. |
---|
| 38 | #Use noarch for scripts. |
---|
| 39 | ARCH=`arch` |
---|
| 40 | |
---|
| 41 | |
---|
| 42 | ########Build and create the pacakge. |
---|
| 43 | #Uncomment the stuff that you dont want or need |
---|
| 44 | |
---|
| 45 | #Unpack source |
---|
| 46 | #(uncomment if not needed) |
---|
| 47 | syn3_unpack $SRC_ARC || exit 1 |
---|
| 48 | |
---|
| 49 | pushd $SRC_DIR || exit 1 |
---|
| 50 | make || exit 1 |
---|
| 51 | make DESTDIR=/tmp/pkg install || exit 1 |
---|
| 52 | rm /tmp/pkg/lib/modules/*/modules.* || exit 1 |
---|
| 53 | popd |
---|
| 54 | |
---|
| 55 | #make main package |
---|
| 56 | syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1 |
---|
| 57 | |
---|
| 58 | |
---|