source: npl/kernel/linux_src/linux_src.SlackBuild @ 1bce4e1

Last change on this file since 1bce4e1 was 1bce4e1, checked in by Edwin Eefting <edwin@datux.nl>, 4 years ago

kernel 4.14.206 and i40e driver

  • Property mode set to 100755
File size: 3.1 KB
RevLine 
[c5c522c]1#!/bin/bash
2#NEED:ncurses_dev
3
4NAME=linux_src
5CWD=`pwd`
6PKGTMP=/tmp/pkgtmp
7
8
9################################################################ UNPACK
10echo "* uitpakken kernel"
11mkdir -p $PKGTMP/usr/src &>/dev/null
12cd $PKGTMP/usr/src
13#tar -xzf $CWD/linux-$VER.tar.gz || exit 1
14
15#unpack basic kernel and apply all incremental patches
[efa4154]16tar -xf $CWD/linux-4.14.tar.xz || exit 1
[c5c522c]17cd linux-* || exit 1
18#if you want to create a newer kernel: just download newest patches, and increase patchlevel
[2bd9b8d]19#also increase .major file to trigger rebuilds!
[1bce4e1]20PATCHLEVEL=206
[efa4154]21VER=4.14.$PATCHLEVEL
[c5c522c]22#bunzip2 $CWD/patch-$VER.bz2 || exit 1
23#gunzip $CWD/patch-$VER.gz || exit 1
24xz -d $CWD/patch-$VER.xz || exit 1
25patch -p1 < $CWD/patch-$VER || exit 1
26cd ..
27mv linux-* linux-$VER #make use the dir-name corresponds to the patched-version
28ln -s linux-$VER linux || exit 1
29cd linux || exit 1
30
31cd $PKGTMP/usr/src/linux || exit 1
32
33
34############################################################### PATCHING
35echo "bootsplash"
36#Nodig voor splashscreen
37#patch -p1 < $CWD/fbsplash-0.9.2-r5-2.6.16.patch || exit 1
38#patch -p1 < $CWD/fbsplash-0.9.2-r5-2.6.18-rc4.patch || exit 1
39#patch -p1 < $CWD/fbsplash-0.9.2-r5-2.6.23-rc2.patch || exit 1
40#fbsplash is hernoemd naar fbcondecor
41#patch -F3 -p1 < $CWD/fbcondecor-0.9.4-2.6.27.patch || exit 1
42#patch -p1 < $CWD/fbcondecor-0.9.6-3.5-rc3.patch || exit 1
43#patch -p1 < $CWD/fbcondecor-3.14b.patch || exit 1
44#patch -F3 -p1 < $CWD/fbcondecor-3.15.patch || exit 1
[6936b89]45#patch  -p1 < $CWD/fbcondecor-3.19.patch || exit 1
46
47#from https://dev.gentoo.org/~mpagano/genpatches/patches-4.9-143.html
[efa4154]48#https://dev.gentoo.org/~mpagano/genpatches/patches-4.14-182.html
[1bce4e1]49patch  -F3 -p1 < $CWD/4200_fbcondecor.patch || exit 1
[c5c522c]50
51
52echo "IMQ (for traffic shaping)"
53#patch -p1 < $CWD/linux-2.6.27.21-imq-test3.diff || exit 1
54#patch -p1 < $CWD/patch-imqmq-3.3.diff || exit 1
55#patch -p1 -F3 < $CWD/linux-3.13-imq.diff || exit 1
56#patch -p1 -F3 < $CWD/linux-3.13.10_hardened_gentoo.diff || exit 1
[6936b89]57#patch -p1  < $CWD/linux-4.4.5-imq.diff || exit 1
[efa4154]58#patch -p1  < $CWD/linux-4.9-imq.diff || exit 1
59#from https://raw.githubusercontent.com/imq/linuximq/master/kernel/v4.x/linux-4.14-imq.diff
60patch -p1  < $CWD/linux-4.14-imq.diff || exit 1
[c5c522c]61
62
63################################################################# CONFIGURE
64echo "* kernel configureren"
65cp $CWD/config $PKGTMP/usr/src/linux/.config || exit 1
66cd $PKGTMP/usr/src/linux || exit 1
67
68
69
70#rename extra version, er mogen geen streepjes inkomen ivm syn3 packaging
71sed '/^EXTRAVERSION = /s/-/_/g' Makefile > Makefile.new || exit 1
72mv Makefile.new Makefile || exit 1
73
74
75#configfiles fixen
76#Als deze wat vraagt, gewoon antwoorden en dan de resultaerende .config naar de svn config kopieren!
77make oldconfig  || exit 1
78
79#nodig om version.h en zo te fix0rren
80make prepare || exit 1
81
82#nodig om modules te bakken
83make scripts || exit 1
84
85
86################################################################ PACKAGE
87
88#versie is nu anders omdat kernel gepatched en configged is:
89KVER="`cat include/config/kernel.release`"
90
91echo "* inpakken kernel_src"
92cd $PKGTMP || exit 1
93makepkg -l y -c n $CWD/$NAME.pkg &>/dev/null ||exit 1
94echo $KVER > $CWD/$NAME.version &&
95arch > $CWD/$NAME.arch
96
Note: See TracBrowser for help on using the repository browser.