source: npl/kernel/linux_src/linux_src.SlackBuild @ 2bd9b8d

gcc484perl-5.22
Last change on this file since 2bd9b8d was 2bd9b8d, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

kernel update to 4.4.72

  • Property mode set to 100755
File size: 2.7 KB
RevLine 
[c5c522c]1#!/bin/bash
2#NEED:ncurses_dev
3
4NAME=linux_src
5CWD=`pwd`
6PKGTMP=/tmp/pkgtmp
7
8
9################################################################ UNPACK
10echo "* uitpakken kernel"
11mkdir -p $PKGTMP/usr/src &>/dev/null
12cd $PKGTMP/usr/src
13#tar -xzf $CWD/linux-$VER.tar.gz || exit 1
14
15#unpack basic kernel and apply all incremental patches
16tar -xf $CWD/linux-4.4.tar.xz || exit 1
17cd linux-* || exit 1
18#if you want to create a newer kernel: just download newest patches, and increase patchlevel
[2bd9b8d]19#also increase .major file to trigger rebuilds!
20PATCHLEVEL=72
[c5c522c]21VER=4.4.$PATCHLEVEL
22#bunzip2 $CWD/patch-$VER.bz2 || exit 1
23#gunzip $CWD/patch-$VER.gz || exit 1
24xz -d $CWD/patch-$VER.xz || exit 1
25patch -p1 < $CWD/patch-$VER || exit 1
26cd ..
27mv linux-* linux-$VER #make use the dir-name corresponds to the patched-version
28ln -s linux-$VER linux || exit 1
29cd linux || exit 1
30
31cd $PKGTMP/usr/src/linux || exit 1
32
33
34############################################################### PATCHING
35echo "bootsplash"
36#Nodig voor splashscreen
37#patch -p1 < $CWD/fbsplash-0.9.2-r5-2.6.16.patch || exit 1
38#patch -p1 < $CWD/fbsplash-0.9.2-r5-2.6.18-rc4.patch || exit 1
39#patch -p1 < $CWD/fbsplash-0.9.2-r5-2.6.23-rc2.patch || exit 1
40#fbsplash is hernoemd naar fbcondecor
41#patch -F3 -p1 < $CWD/fbcondecor-0.9.4-2.6.27.patch || exit 1
42#patch -p1 < $CWD/fbcondecor-0.9.6-3.5-rc3.patch || exit 1
43#patch -p1 < $CWD/fbcondecor-3.14b.patch || exit 1
44#patch -F3 -p1 < $CWD/fbcondecor-3.15.patch || exit 1
45patch  -p1 < $CWD/fbcondecor-3.19.patch || exit 1
46
47
48echo "IMQ (for traffic shaping)"
49#patch -p1 < $CWD/linux-2.6.27.21-imq-test3.diff || exit 1
50#patch -p1 < $CWD/patch-imqmq-3.3.diff || exit 1
51#patch -p1 -F3 < $CWD/linux-3.13-imq.diff || exit 1
52#patch -p1 -F3 < $CWD/linux-3.13.10_hardened_gentoo.diff || exit 1
53patch -p1  < $CWD/linux-4.4.5-imq.diff || exit 1
54
55
56################################################################# CONFIGURE
57echo "* kernel configureren"
58cp $CWD/config $PKGTMP/usr/src/linux/.config || exit 1
59cd $PKGTMP/usr/src/linux || exit 1
60
61
62
63#rename extra version, er mogen geen streepjes inkomen ivm syn3 packaging
64sed '/^EXTRAVERSION = /s/-/_/g' Makefile > Makefile.new || exit 1
65mv Makefile.new Makefile || exit 1
66
67
68#configfiles fixen
69#Als deze wat vraagt, gewoon antwoorden en dan de resultaerende .config naar de svn config kopieren!
70make oldconfig  || exit 1
71
72#nodig om version.h en zo te fix0rren
73make prepare || exit 1
74
75#nodig om modules te bakken
76make scripts || exit 1
77
78
79################################################################ PACKAGE
80
81#versie is nu anders omdat kernel gepatched en configged is:
82KVER="`cat include/config/kernel.release`"
83
84echo "* inpakken kernel_src"
85cd $PKGTMP || exit 1
86makepkg -l y -c n $CWD/$NAME.pkg &>/dev/null ||exit 1
87echo $KVER > $CWD/$NAME.version &&
88arch > $CWD/$NAME.arch
89
Note: See TracBrowser for help on using the repository browser.