Last change
on this file was
c5c522c,
checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago
|
initial commit, transferred from cleaned syn3 svn tree
|
-
Property mode set to
100755
|
File size:
1.0 KB
|
Line | |
---|
1 | #!/bin/bash |
---|
2 | VERSION=0.97 |
---|
3 | PKGROOT=/tmp/pkg |
---|
4 | CWD=`pwd` |
---|
5 | set -e |
---|
6 | |
---|
7 | #onze config |
---|
8 | mkdir -p $PKGROOT/etc/ |
---|
9 | cp clamd.conf $PKGROOT/etc/clamd.conf || exit 1 |
---|
10 | cp freshclam.conf $PKGROOT/etc/freshclam.conf || exit 1 |
---|
11 | chown root:root $PKGROOT/etc/clamd.conf $PKGROOT/etc/freshclam.conf || exit 1 |
---|
12 | chmod 644 $PKGROOT/etc/clamd.conf $PKGROOT/etc/freshclam.conf || exit 1 |
---|
13 | |
---|
14 | mkdir -p $PKGROOT/var/run/clamav || exit 1 |
---|
15 | mkdir -p $PKGROOT/usr/share/clamav || exit 1 |
---|
16 | |
---|
17 | #clumsy workaround to prevent scanning proxys from thinking we are a virus ourselfs: |
---|
18 | cp eicar.com.* $PKGROOT/usr/share/clamav || exit 1 |
---|
19 | |
---|
20 | #cronupdater and tester |
---|
21 | mkdir -p $PKGROOT/etc/cron.hourly || exit 1 |
---|
22 | cp syn3-clamav $PKGROOT/etc/cron.hourly || exit 1 |
---|
23 | chmod +x $PKGROOT/etc/cron.hourly/* |
---|
24 | |
---|
25 | #post install scripts |
---|
26 | chmod +x $CWD/post.* |
---|
27 | mkdir -p $PKGROOT/etc/postinst.d |
---|
28 | cp $CWD/post.* $PKGROOT/etc/postinst.d |
---|
29 | |
---|
30 | |
---|
31 | |
---|
32 | #copy run script |
---|
33 | mkdir -p $PKGROOT/service/clamav |
---|
34 | chmod +x $CWD/run |
---|
35 | cp $CWD/run $PKGROOT/service/clamav |
---|
36 | |
---|
37 | #make main package |
---|
38 | syn3_makepkg $PKGROOT clamav_conf $VERSION `arch` || exit 1 |
---|
39 | |
---|
Note: See
TracBrowser
for help on using the repository browser.