gcc484perl-5.22
Last change
on this file since 1163be4 was
1163be4,
checked in by Edwin Eefting <edwin@datux.nl>, 7 years ago
|
Migrated from Zarafa 7.2.4 to Kopano 8.6.6, including webapp
|
-
Property mode set to
100755
|
File size:
792 bytes
|
Line | |
---|
1 | #!/bin/bash |
---|
2 | ##NEED:nodejs |
---|
3 | ##NEED:git |
---|
4 | #NEED:apache_ant |
---|
5 | #NEED:jdk |
---|
6 | |
---|
7 | #######Essential package info. |
---|
8 | #Change these if autodetection fails. |
---|
9 | |
---|
10 | #Name of the Syn-3 package that we are going to create |
---|
11 | NAME=`basename $0|sed 's/.SlackBuild//'` |
---|
12 | |
---|
13 | |
---|
14 | #Architecture that the created binaries run on. |
---|
15 | #Use noarch for scripts. |
---|
16 | ARCH=`uname -m` |
---|
17 | |
---|
18 | #from this point on, exit on errors: |
---|
19 | set -e |
---|
20 | |
---|
21 | ########Build and create the pacakge. |
---|
22 | #Uncomment the stuff that you dont want or need |
---|
23 | |
---|
24 | SRC_DIR=kopano-webapp |
---|
25 | VER=3.4.19 |
---|
26 | |
---|
27 | pushd $SRC_DIR |
---|
28 | PATH=$PATH:/usr/lib/ant/bin |
---|
29 | PATH=$PATH:/usr/lib/java/bin/ |
---|
30 | |
---|
31 | ant deploy |
---|
32 | ant deploy-plugins |
---|
33 | #npm install |
---|
34 | popd |
---|
35 | |
---|
36 | mkdir -p /tmp/pkg/var/www/htdocs/syn3 |
---|
37 | mv $SRC_DIR/deploy /tmp/pkg/var/www/htdocs/syn3/kopano-webapp || exit 1 |
---|
38 | |
---|
39 | |
---|
40 | #make main package |
---|
41 | syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1 |
---|
Note: See
TracBrowser
for help on using the repository browser.