source: npl/mailserver/kopano_webapp/kopano_webapp.SlackBuild @ 1163be4

gcc484perl-5.22
Last change on this file since 1163be4 was 1163be4, checked in by Edwin Eefting <edwin@datux.nl>, 7 years ago

Migrated from Zarafa 7.2.4 to Kopano 8.6.6, including webapp

  • Property mode set to 100755
File size: 792 bytes
Line 
1#!/bin/bash
2##NEED:nodejs
3##NEED:git
4#NEED:apache_ant
5#NEED:jdk
6
7#######Essential package info.
8#Change these if autodetection fails.
9
10#Name of the Syn-3 package that we are going to create
11NAME=`basename $0|sed 's/.SlackBuild//'`
12
13
14#Architecture that the created binaries run on.
15#Use noarch for scripts.
16ARCH=`uname -m`
17
18#from this point on, exit on errors:
19set -e
20
21########Build and create the pacakge.
22#Uncomment the stuff that you dont want or need
23
24SRC_DIR=kopano-webapp
25VER=3.4.19
26
27pushd $SRC_DIR
28PATH=$PATH:/usr/lib/ant/bin
29PATH=$PATH:/usr/lib/java/bin/
30
31ant deploy
32ant deploy-plugins
33#npm install
34popd
35
36mkdir -p /tmp/pkg/var/www/htdocs/syn3
37mv $SRC_DIR/deploy /tmp/pkg/var/www/htdocs/syn3/kopano-webapp || exit 1
38
39
40#make main package
41syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
Note: See TracBrowser for help on using the repository browser.