[4f7cda5] | 1 | #!/bin/bash |
---|
| 2 | |
---|
| 3 | ##NEED:... |
---|
| 4 | #DEP:openssl |
---|
| 5 | |
---|
| 6 | #######Essential package info. |
---|
| 7 | #Change these if autodetection fails. |
---|
| 8 | |
---|
| 9 | #Name of the Syn-3 package that we are going to create |
---|
| 10 | NAME=`basename $0|sed 's/.SlackBuild//'` |
---|
| 11 | |
---|
| 12 | #Archive of the sourcefiles to unpack |
---|
| 13 | SRC_ARC=`ls *.tar.* *.zip 2>/dev/null` |
---|
| 14 | |
---|
| 15 | #Version of the sourcefiles |
---|
| 16 | VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g' | sed 's/\.zip$//g'` |
---|
| 17 | |
---|
| 18 | #Architecture that the created binaries run on. |
---|
| 19 | #Use noarch for scripts. |
---|
| 20 | ARCH=`uname -m` |
---|
| 21 | |
---|
| 22 | #from this point on, exit on errors: |
---|
| 23 | set -e |
---|
| 24 | |
---|
| 25 | ########Build and create the pacakge. |
---|
| 26 | #Uncomment the stuff that you dont want or need |
---|
| 27 | |
---|
| 28 | #Unpack source |
---|
| 29 | #(uncomment if not needed) |
---|
| 30 | syn3_unpack $SRC_ARC |
---|
| 31 | |
---|
| 32 | #Directory where the sourcefiles are unpacked. |
---|
| 33 | #(you might have to adjust this if autodetection fails) |
---|
| 34 | SRC_DIR=`ls -c|head -1` |
---|
| 35 | |
---|
| 36 | #apply patches |
---|
| 37 | patch -p0 -d $SRC_DIR < libdomainkeys-0.69.diff || exit 1 |
---|
| 38 | |
---|
| 39 | pushd $SRC_DIR |
---|
| 40 | |
---|
| 41 | make |
---|
| 42 | |
---|
| 43 | mkdir -p /tmp/pkg/usr/include |
---|
| 44 | mkdir -p /tmp/pkg/usr/lib |
---|
| 45 | |
---|
| 46 | cp domainkeys.h /tmp/pkg/usr/include |
---|
| 47 | cp libdomainkeys.a /tmp/pkg/usr/lib |
---|
| 48 | |
---|
| 49 | popd |
---|
| 50 | |
---|
| 51 | #strip bins and other stuff |
---|
| 52 | syn3_strip /tmp/pkg || exit 1 |
---|
| 53 | |
---|
| 54 | #move development stuff and create seperate development package |
---|
| 55 | syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1 |
---|
| 56 | syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1 |
---|
| 57 | |
---|
| 58 | #make main package |
---|
| 59 | syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1 |
---|