source: npl/mailserver/vpopmail/vpopmail.SlackBuild @ cd8630b

gcc484perl-5.22
Last change on this file since cd8630b was cd8630b, checked in by Edwin Eefting <edwin@datux.nl>, 7 years ago

improved logging. auth and tls support. qmail-submission on port 587 (requires both tls and auth to relay mails from the internet)

  • Property mode set to 100755
File size: 2.4 KB
RevLine 
[4f7cda5]1#!/bin/bash
2
3##NEED:...
4##DEP:..
5#NEED:netqmail
[cd8630b]6##DEP:openldap
[4f7cda5]7
8
9#######Essential package info.
10#Change these if autodetection fails.
11
12#Name of the Syn-3 package that we are going to create
13NAME=`basename $0|sed 's/.SlackBuild//'`
14
15#Archive of the sourcefiles to unpack
16SRC_ARC=`ls *.tar.* *.zip 2>/dev/null`
17
18#Version of the sourcefiles
19VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g' | sed 's/\.zip$//g'`
20
21#Architecture that the created binaries run on.
22#Use noarch for scripts.
23ARCH=`uname -m`
24
25#from this point on, exit on errors:
26set -e
27
28########Build and create the pacakge.
29#Uncomment the stuff that you dont want or need
30
31#Unpack source
32#(uncomment if not needed)
33syn3_unpack $SRC_ARC
34
35#Directory where the sourcefiles are unpacked.
36#(you might have to adjust this if autodetection fails)
37SRC_DIR=`ls -c|head -1`
38
39#apply patches
40#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
41
42pushd $SRC_DIR
43
44groupadd -g 89 vchkpw
45useradd -g vchkpw -u 89 -d /home/vpopmail vpopmail
46#AUTOMAKE: Configure
47#Some usefull stuff you sometimes need to set:
48#export LDFLAGS="-L/usr/X11/lib/ -L/usr/lib/mysql/"
49#export LD_LIBRARY_PATH=/usr/lib/mysql
50#export VPATH=$LD_LIBRARY_PATH
51#export CFLAGS="-std=c89"
52#export CFLAGS="-fgnu89-inline" #If "multiple definition of `foo'" Also see http://gcc.gnu.org/gcc-4.3/porting_to.html
53MAKE_OPTS=""
54./configure \
55                --prefix=/usr \
56        --enable-qmaildir=/var/qmail/ \
57        --enable-qmail-newu=/var/qmail/bin/qmail-newu \
58        --enable-qmail-inject=/var/qmail/bin/qmail-inject \
59        --enable-qmail-newmrh=/var/qmail/bin/qmail-newmrh \
60        --disable-roaming-users \
[cd8630b]61        --enable-libdir=/usr/lib \
[4f7cda5]62        --enable-logging=p \
63        --disable-clear-passwd \
64        --enable-auth-logging \
65        --disable-valias \
66        --disable-passwd \
67        --enable-qmail-ext \
68        --enable-learn-passwords
69
70
71#AUTOMAKE: Compile
72make $MAKE_OPTS || exit 1
73
74
75#AUTOMAKE: Install
76mkdir -p /tmp/pkg &>/dev/null
77make pkgconfigdir=/usr/lib/pkgconfig install_prefix=/tmp/pkg DESTDIR=/tmp/pkg INSTALL_ROOT=/tmp/pkg install_root=/tmp/pkg $MAKE_OPTS install || exit 1
78popd
79
80#strip bins and other stuff
81syn3_strip /tmp/pkg || exit 1
82
83#move development stuff and create seperate development package
84syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
85syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
86
87#make main package
88syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
Note: See TracBrowser for help on using the repository browser.