source: npl/mailserver/z_merge_agent/z_merge_agent.SlackBuild @ a2d969e

perl-5.22
Last change on this file since a2d969e was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 2.1 KB
Line 
1#!/bin/bash
2#Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild
3#Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
4#Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
5##################################### Build dependency info:
6
7#Strict build-dependencies
8#Our package will be automaticly rebuilded if there is a major change in a DEP package.
9#(this is recommended for most dependencys)
10##DEP:linux
11##DEP:linux_src
12##DEP:openldap
13
14#Loose build-dependencies
15#The package will be installed in the buildroot during buidling, but no automatic rebuild will occur.
16#(not recommended)
17##NEED:doxygen
18
19#######Essential package info.
20#Change these if autodetection fails.
21
22#Name of the Syn-3 package that we are going to create
23NAME=`basename $0|sed 's/.SlackBuild//'`
24
25#Archive of the sourcefiles to unpack
26SRC_ARC=`ls *.tar.* *.zip 2>/dev/null`
27
28#Version of the sourcefiles
29VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g' | sed 's/\.zip$//g'`
30
31#Architecture that the created binaries run on.
32#Use noarch for scripts.
33ARCH=`uname -m`
34
35#from this point on, exit on errors:
36set -e
37
38########Build and create the pacakge.
39#Uncomment the stuff that you dont want or need
40
41#Unpack source
42#(uncomment if not needed)
43syn3_unpack $SRC_ARC
44mkdir -p /tmp/pkg &>/dev/null
45#Directory where the sourcefiles are unpacked.
46#(you might have to adjust this if autodetection fails)
47SRC_DIR=`ls -c|head -1`
48
49
50mkdir -p /tmp/pkg/etc/postinst.d/ ||exit 1
51cp post.z_merge_agent /tmp/pkg/etc/postinst.d/ ||exit 1
52chmod +x /tmp/pkg/etc/postinst.d/* ||exit 1
53
54
55pushd $SRC_DIR
56
57mkdir -p /tmp/pkg/usr/lib
58cp -r z-merge /tmp/pkg/usr/lib
59mkdir -p /tmp/pkg/var/log/z-merge
60mkdir -p /tmp/pkg/etc/z-merge
61cp ../agent-cfg.php /tmp/pkg/etc/z-merge/agent-cfg.php.new
62mkdir -p /tmp/pkg/service/z_merge_agent
63cp ../run /tmp/pkg/service/z_merge_agent
64chmod +x /tmp/pkg/service/z_merge_agent/run
65popd
66
67cp autocheck.php /tmp/pkg/usr/lib/z-merge/tools
68
69#make main package
70syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
71
72
73
Note: See TracBrowser for help on using the repository browser.