1 | #!/bin/bash |
---|
2 | #Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild |
---|
3 | #Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven. |
---|
4 | #Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden. |
---|
5 | ##################################### Build dependency info: |
---|
6 | |
---|
7 | #Strict build-dependencies |
---|
8 | #Our package will be automaticly rebuilded if there is a major change in a DEP package. |
---|
9 | #(this is recommended for most dependencys) |
---|
10 | ##DEP:linux |
---|
11 | ##DEP:linux_src |
---|
12 | ##DEP:openldap |
---|
13 | |
---|
14 | #Loose build-dependencies |
---|
15 | #The package will be installed in the buildroot during buidling, but no automatic rebuild will occur. |
---|
16 | #(not recommended) |
---|
17 | ##NEED:doxygen |
---|
18 | #NEED:apache_ant |
---|
19 | |
---|
20 | #######Essential package info. |
---|
21 | #Change these if autodetection fails. |
---|
22 | |
---|
23 | #Name of the Syn-3 package that we are going to create |
---|
24 | NAME=`basename $0|sed 's/.SlackBuild//'` |
---|
25 | |
---|
26 | #Archive of the sourcefiles to unpack |
---|
27 | SRC_ARC=`ls *.tar.* 2>/dev/null` |
---|
28 | |
---|
29 | #Version of the sourcefiles |
---|
30 | VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g' | sed 's/\.zip$//g'` |
---|
31 | |
---|
32 | #Architecture that the created binaries run on. |
---|
33 | #Use noarch for scripts. |
---|
34 | ARCH=`uname -m` |
---|
35 | |
---|
36 | #from this point on, exit on errors: |
---|
37 | set -e |
---|
38 | |
---|
39 | ########Build and create the pacakge. |
---|
40 | #Uncomment the stuff that you dont want or need |
---|
41 | |
---|
42 | #Unpack source |
---|
43 | #(uncomment if not needed) |
---|
44 | syn3_unpack $SRC_ARC |
---|
45 | |
---|
46 | #Directory where the sourcefiles are unpacked. |
---|
47 | #(you might have to adjust this if autodetection fails) |
---|
48 | SRC_DIR=`ls -c|head -1` |
---|
49 | |
---|
50 | #apply patches |
---|
51 | #patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1 |
---|
52 | #patch -p1 -d $SRC_DIR < movemessage.patch || exit 1 |
---|
53 | |
---|
54 | #plugins (they need to be ant deployed and this needs file from the webapp source package) |
---|
55 | FILEVIEWER=fileviewer-master-8f37528886871763b0faa061a6c6c7f7537cd88e |
---|
56 | unzip $FILEVIEWER.zip |
---|
57 | mv $FILEVIEWER $SRC_DIR/plugins/fileviewer |
---|
58 | |
---|
59 | |
---|
60 | pushd $SRC_DIR |
---|
61 | PATH=$PATH:/usr/lib/ant/bin |
---|
62 | make antdeploy |
---|
63 | mkdir -p /tmp/pkg/var/www/htdocs/syn3/ |
---|
64 | mv deploy /tmp/pkg/var/www/htdocs/syn3/zarafa_webapp |
---|
65 | popd |
---|
66 | |
---|
67 | #enable some plugins |
---|
68 | sed -i "s/.*PLUGIN_GMAPS_USER_DEFAULT_ENABLE.*/define('PLUGIN_GMAPS_USER_DEFAULT_ENABLE', true);/" /tmp/pkg/var/www/htdocs/syn3/zarafa_webapp/plugins/gmaps/config.php |
---|
69 | |
---|
70 | |
---|
71 | #make main package |
---|
72 | syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1 |
---|
73 | |
---|
74 | |
---|
75 | |
---|