source: npl/mailserver/zpush/zpush.SlackBuild @ 7c410f9

Last change on this file since 7c410f9 was 1163be4, checked in by Edwin Eefting <edwin@datux.nl>, 7 years ago

Migrated from Zarafa 7.2.4 to Kopano 8.6.6, including webapp

  • Property mode set to 100755
File size: 2.1 KB
Line 
1#!/bin/bash
2#Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild
3#Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
4#Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
5##################################### Build dependency info:
6
7#Strict build-dependencies
8#Our package will be automaticly rebuilded if there is a major change in a DEP package.
9#(this is recommended for most dependencys)
10##DEP:linux
11##DEP:linux_src
12##DEP:openldap
13
14#Loose build-dependencies
15#The package will be installed in the buildroot during buidling, but no automatic rebuild will occur.
16#(not recommended)
17##NEED:doxygen
18
19#######Essential package info.
20#Change these if autodetection fails.
21
22#Name of the Syn-3 package that we are going to create
23NAME=`basename $0|sed 's/.SlackBuild//'`
24
25#Archive of the sourcefiles to unpack
26#SRC_ARC=`ls *.tar.* *.zip 2>/dev/null`
27
28#Version of the sourcefiles
29#VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g' | sed 's/\.zip$//g'`
30VER=2.4.4
31
32#Architecture that the created binaries run on.
33#Use noarch for scripts.
34ARCH=`uname -m`
35
36#from this point on, exit on errors:
37set -e
38
39########Build and create the pacakge.
40#Uncomment the stuff that you dont want or need
41
42#Unpack source
43#(uncomment if not needed)
44#syn3_unpack $SRC_ARC
45
46#Directory where the sourcefiles are unpacked.
47#(you might have to adjust this if autodetection fails)
48SRC_DIR=z-push
49
50
51mkdir -p /tmp/pkg/usr/share
52mv $SRC_DIR/src /tmp/pkg/usr/share/z-push || exit 1
53
54#zpush config
55#cp config.php /tmp/pkg//usr/share/z-push || exit 1
56
57#apache config
58mkdir -p /tmp/pkg/etc/apache2/conf.d
59cp z-push.conf /tmp/pkg/etc/apache2/conf.d || exit 1
60cp z-push-autodiscover.conf /tmp/pkg/etc/apache2/conf.d || exit 1
61
62#htacces with correct php settings
63#cp .htaccess /tmp/pkg//usr/share/z-push || exit 1
64
65#postinst
66mkdir -p /tmp/pkg/etc/postinst.d/
67cp post.z-push /tmp/pkg/etc/postinst.d/
68chmod +x /tmp/pkg/etc/postinst.d/post.z-push || exit 1
69
70
71#make main package
72syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
73
74
75
Note: See TracBrowser for help on using the repository browser.