[c5c522c] | 1 | #!/bin/bash |
---|
| 2 | #DIT IS EEN ZEER OUDE LCDPROC |
---|
| 3 | #ik heb hier ooit een driver voor geschreven, voor mn eigen display. geen zin om te porten vandaar deze _edwin versie. |
---|
| 4 | |
---|
| 5 | #Strict build-dependencies. |
---|
| 6 | #Only use when really neccesary, this will rebuild our package if the dependencie has changed: |
---|
| 7 | ##DEP:linux |
---|
| 8 | ##DEP:linux_src |
---|
| 9 | |
---|
| 10 | #Loose build-dependencies. |
---|
| 11 | #Use this to specify the packages that are required to build our package: |
---|
| 12 | ##NEED:libcairo |
---|
| 13 | ##NEED:glib |
---|
| 14 | ##NEED:gtk+ |
---|
| 15 | ##NEED:glib2 |
---|
| 16 | ##NEED:gtk+2 |
---|
| 17 | ##NEED:xorg_lib |
---|
| 18 | ##NEED:xorg_proto |
---|
| 19 | ##NEED:ncurses |
---|
| 20 | |
---|
| 21 | #######Essential package info. |
---|
| 22 | #Change these if autodetection fails. |
---|
| 23 | |
---|
| 24 | #Name of the Syn-3 package that we are going to create |
---|
| 25 | NAME=`basename $0|sed 's/.SlackBuild//'` |
---|
| 26 | |
---|
| 27 | #Archive of the sourcefiles to unpack |
---|
| 28 | #SRC_ARC=`ls *.tar.*` |
---|
| 29 | |
---|
| 30 | #Version of the sourcefiles |
---|
| 31 | VER=0.4pre9 |
---|
| 32 | |
---|
| 33 | #Directory of the sourcefiles to build (after optional unpacking) |
---|
| 34 | SRC_DIR=src |
---|
| 35 | |
---|
| 36 | #Architecture that the created binaries run on. |
---|
| 37 | #Use noarch for scripts. |
---|
| 38 | ARCH=`arch` |
---|
| 39 | |
---|
| 40 | |
---|
| 41 | ########Build and create the pacakge. |
---|
| 42 | #Uncomment the stuff that you dont want or need |
---|
| 43 | |
---|
| 44 | #Unpack source |
---|
| 45 | #(uncomment if not needed) |
---|
| 46 | #syn3_unpack $SRC_ARC || exit 1 |
---|
| 47 | |
---|
| 48 | #apply patches |
---|
| 49 | #patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1 |
---|
| 50 | |
---|
| 51 | #build and install sourcefiles |
---|
| 52 | #(use one of the other syn3_build_* scripts when needed) |
---|
| 53 | export CONFIGURE_OPTS="" |
---|
| 54 | export MAKE_OPTS="" |
---|
| 55 | #export NOTEST=1 |
---|
| 56 | #syn3_build_automake $SRC_DIR /tmp/pkg || exit 1 |
---|
| 57 | cd $SRC_DIR |
---|
| 58 | #make geeft errors maar boeit nie |
---|
| 59 | make -j1 |
---|
| 60 | mkdir -p /tmp/pkg/bin |
---|
| 61 | cp server/LCDd /tmp/pkg/bin/LCDd || exit 1 |
---|
| 62 | chmod +x /tmp/pkg/bin/LCDd || exit 1 |
---|
| 63 | #make -j1 install || exit 1 |
---|
| 64 | cd .. |
---|
| 65 | |
---|
| 66 | #strip bins and other stuff |
---|
| 67 | syn3_strip /tmp/pkg || exit 1 |
---|
| 68 | |
---|
| 69 | #move development stuff and create seperate development package |
---|
| 70 | syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1 |
---|
| 71 | syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1 |
---|
| 72 | |
---|
| 73 | #make main package |
---|
| 74 | syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1 |
---|
| 75 | |
---|
| 76 | |
---|