source: npl/mediabox/libmad/libmad.SlackBuild @ c5c522c

gcc484ntopperl-5.22
Last change on this file since c5c522c was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 2.3 KB
Line 
1#!/bin/bash
2#Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild
3#Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
4#Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
5##################################### Build dependency info:
6
7#Strict build-dependencies.
8#Only use when really neccesary, this will rebuild our package if the dependencie has changed:
9##DEP:linux
10##DEP:linux_src
11
12#Loose build-dependencies.
13#Use this to specify the packages that are required to build our package:
14##NEED:libcairo
15##NEED:glib
16##NEED:gtk+
17##NEED:glib2
18##NEED:gtk+2
19##NEED:xorg_lib
20##NEED:xorg_proto
21
22#######Essential package info.
23#Change these if autodetection fails.
24
25#Name of the Syn-3 package that we are going to create
26NAME=`basename $0|sed 's/.SlackBuild//'`
27
28#Archive of the sourcefiles to unpack
29SRC_ARC=`ls *.tar.*`
30
31#Version of the sourcefiles
32VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g'`
33
34#Directory of the sourcefiles to build (after optional unpacking)
35SRC_DIR=`echo $SRC_ARC| sed 's/\.tar\..*$//g'`
36
37#Architecture that the created binaries run on.
38#Use noarch for scripts.
39ARCH=`arch`
40
41
42########Build and create the pacakge.
43#Uncomment the stuff that you dont want or need
44
45#Unpack source
46#(uncomment if not needed)
47syn3_unpack $SRC_ARC || exit 1
48
49#apply patches
50patch -p1 -d $SRC_DIR < libmad_0.15.1b-5.diff || exit 1
51
52sed 's/-fforce-mem//g' -i $SRC_DIR/configure
53
54#build and install sourcefiles
55#(use one of the other syn3_build_* scripts when needed)
56        # --enable-speed                 optimize for speed over accuracy
57        # --enable-accuracy              optimize for accuracy over speed
58        # --enable-experimental  enable code using the EXPERIMENTAL
59export CONFIGURE_OPTS="--enable-accuracy"
60export MAKE_OPTS=""
61#export NOTEST=1
62syn3_build_automake $SRC_DIR /tmp/pkg || exit 1
63
64mkdir -p /tmp/pkg/usr/lib/pkgconfig
65cp $SRC_DIR/debian/mad.pc /tmp/pkg/usr/lib/pkgconfig || exit 1
66
67#strip bins and other stuff
68syn3_strip /tmp/pkg || exit 1
69
70#move development stuff and create seperate development package
71syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
72syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
73
74#make main package
75syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
76
77
Note: See TracBrowser for help on using the repository browser.