source: npl/mediabox/libsdl/libsdl.SlackBuild

Last change on this file was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 2.0 KB
Line 
1#!/bin/bash
2#Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild
3#Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
4#Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
5##################################### Build dependency info:
6
7#Strict build-dependencies.
8#Only use when really neccesary, this will rebuild our package if the dependencie has changed:
9##DEP:linux
10##DEP:linux_src
11
12#Loose build-dependencies.
13#Use this to specify the packages that are required to build our package:
14##NEED:libcairo
15##NEED:glib
16##NEED:gtk+
17##NEED:glib2
18##NEED:gtk+2
19##NEED:xorg_lib
20##NEED:xorg_proto
21#DEP:alsa_lib
22#DEP:xorg_proto
23#DEP:xorg_lib
24#DEP:DirectFB
25#DEP:libmesa
26
27#######Essential package info.
28#Change these if autodetection fails.
29
30#Name of the Syn-3 package that we are going to create
31NAME=`basename $0|sed 's/.SlackBuild//'`
32
33#Archive of the sourcefiles to unpack
34SRC_ARC=`ls *.tar.*`
35
36#Version of the sourcefiles
37VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g'`
38
39#Directory of the sourcefiles to build (after optional unpacking)
40SRC_DIR=`echo $SRC_ARC| sed 's/\.tar\..*$//g'`
41
42#Architecture that the created binaries run on.
43#Use noarch for scripts.
44ARCH=`arch`
45
46
47########Build and create the pacakge.
48#Uncomment the stuff that you dont want or need
49
50#Unpack source
51#(uncomment if not needed)
52syn3_unpack $SRC_ARC || exit 1
53
54#apply patches
55#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
56
57#build and install sourcefiles
58#(use one of the other syn3_build_* scripts when needed)
59export CONFIGURE_OPTS=""
60export MAKE_OPTS=""
61#export NOTEST=1
62syn3_build_automake $SRC_DIR /tmp/pkg || exit 1
63
64#strip bins and other stuff
65syn3_strip /tmp/pkg || exit 1
66
67#move development stuff and create seperate development package
68syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
69syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
70
71#make main package
72syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
73
74
Note: See TracBrowser for help on using the repository browser.