source: npl/mediabox/libsdl_mixer/libsdl_mixer.SlackBuild @ c5c522c

gcc484ntopperl-5.22
Last change on this file since c5c522c was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 2.0 KB
Line 
1#!/bin/bash
2#Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild
3#Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
4#Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
5##################################### Build dependency info:
6
7#Strict build-dependencies.
8#Only use when really neccesary, this will rebuild our package if the dependencie has changed:
9##DEP:linux
10##DEP:linux_src
11
12#Loose build-dependencies.
13#Use this to specify the packages that are required to build our package:
14##NEED:libcairo
15##NEED:glib
16##NEED:gtk+
17##NEED:glib2
18##NEED:gtk+2
19##NEED:xorg_lib
20##NEED:xorg_proto
21#DEP:libsdl
22
23#######Essential package info.
24#Change these if autodetection fails.
25
26#Name of the Syn-3 package that we are going to create
27NAME=`basename $0|sed 's/.SlackBuild//'`
28
29#Archive of the sourcefiles to unpack
30SRC_ARC=`ls *.tar.*`
31
32#Version of the sourcefiles
33VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g'`
34
35#Directory of the sourcefiles to build (after optional unpacking)
36SRC_DIR=`echo $SRC_ARC| sed 's/\.tar\..*$//g'`
37
38#Architecture that the created binaries run on.
39#Use noarch for scripts.
40ARCH=`uname -m`
41
42
43########Build and create the pacakge.
44#Uncomment the stuff that you dont want or need
45
46#Unpack source
47#(uncomment if not needed)
48syn3_unpack $SRC_ARC || exit 1
49
50#apply patches
51#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
52
53#build and install sourcefiles
54#./configure optiones:
55export CONFIGURE_OPTS=""
56#options for all make commands:
57export MAKE_OPTS=""
58#skip testing:
59#export NOTEST=1
60#extra optiones for the make install command, use with INSTALL_BASE for example:
61export INSTALL_OPTS=""
62syn3_build_automake $SRC_DIR /tmp/pkg || exit 1
63
64#strip bins and other stuff
65syn3_strip /tmp/pkg || exit 1
66
67#move development stuff and create seperate development package
68syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
69syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
70
71#make main package
72syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
73
74
Note: See TracBrowser for help on using the repository browser.