source: npl/mediabox/libsoup/libsoup.SlackBuild @ c5c522c

gcc484ntopperl-5.22
Last change on this file since c5c522c was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 2.3 KB
Line 
1#!/bin/bash
2#Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild
3#Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
4#Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
5##################################### Build dependency info:
6
7#DEP:glib2
8#DEP:libxml2
9#DEP:zlib
10#DEP:libffi
11
12#######Essential package info.
13#Change these if autodetection fails.
14
15#Name of the Syn-3 package that we are going to create
16NAME=`basename $0|sed 's/.SlackBuild//'`
17
18#Archive of the sourcefiles to unpack
19SRC_ARC=`ls *.tar.* *.zip 2>/dev/null`
20
21#Version of the sourcefiles
22VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g' | sed 's/\.zip$//g'`
23
24#Architecture that the created binaries run on.
25#Use noarch for scripts.
26ARCH=`uname -m`
27
28#from this point on, exit on errors:
29set -e
30
31########Build and create the pacakge.
32#Uncomment the stuff that you dont want or need
33
34#Unpack source
35#(uncomment if not needed)
36syn3_unpack $SRC_ARC
37
38#Directory where the sourcefiles are unpacked.
39#(you might have to adjust this if autodetection fails)
40SRC_DIR=`ls -c|head -1`
41
42#apply patches
43#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
44
45pushd $SRC_DIR
46
47#AUTOMAKE: Configure
48#Some usefull stuff you sometimes need to set:
49#export LDFLAGS="-L/usr/X11/lib/ -L/usr/lib/mysql/"
50#export LD_LIBRARY_PATH=/usr/lib/mysql
51#export VPATH=$LD_LIBRARY_PATH
52MAKE_OPTS=""
53./configure --prefix=/usr --disable-ssl --without-gnome || exit 1
54
55#AUTOMAKE: Compile
56make $MAKE_OPTS >/dev/null || exit 1
57
58#AUTOMAKE: Test (optional)
59#if grep ^check: Makefile; then
60#       make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1
61#       make $MAKE_OPTS check || exit 1
62#elif grep ^test: Makefile; then
63#       make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1
64#       make $MAKE_OPTS test || exit 1
65#fi
66
67#AUTOMAKE: Install
68mkdir -p /tmp/pkg &>/dev/null
69make pkgconfigdir=/usr/lib/pkgconfig install_prefix=/tmp/pkg DESTDIR=/tmp/pkg INSTALL_ROOT=/tmp/pkg install_root=/tmp/pkg $MAKE_OPTS install >/dev/null || exit 1
70popd
71
72#strip bins and other stuff
73syn3_strip /tmp/pkg || exit 1
74
75#move development stuff and create seperate development package
76syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
77syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
78
79#make main package
80syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
81
82
83
Note: See TracBrowser for help on using the repository browser.