source: npl/mediabox/libspiff/libspiff.SlackBuild

Last change on this file was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 1.9 KB
Line 
1#!/bin/bash
2#Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild
3#Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
4#Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
5##################################### Build dependency info:
6
7#Strict build-dependencies.
8#Only use when really neccesary, this will rebuild our package if the dependencie has changed:
9##DEP:linux
10##DEP:linux_src
11
12#Loose build-dependencies.
13#Use this to specify the packages that are required to build our package:
14##NEED:libcairo
15##NEED:glib
16##NEED:gtk+
17##NEED:glib2
18##NEED:gtk+2
19##NEED:xorg_lib
20##NEED:xorg_proto
21#DEP:expat
22#DEP:uriparser
23
24#######Essential package info.
25#Change these if autodetection fails.
26
27#Name of the Syn-3 package that we are going to create
28NAME=`basename $0|sed 's/.SlackBuild//'`
29
30#Archive of the sourcefiles to unpack
31SRC_ARC=`ls *.tar.*`
32
33#Version of the sourcefiles
34VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g'`
35
36#Directory of the sourcefiles to build (after optional unpacking)
37SRC_DIR=`echo $SRC_ARC| sed 's/\.tar\..*$//g'`
38
39#Architecture that the created binaries run on.
40#Use noarch for scripts.
41ARCH=`arch`
42
43
44########Build and create the pacakge.
45#Uncomment the stuff that you dont want or need
46
47#Unpack source
48#(uncomment if not needed)
49syn3_unpack $SRC_ARC || exit 1
50
51#apply patches
52#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
53
54#build and install sourcefiles
55#(use one of the other syn3_build_* scripts when needed)
56export CONFIGURE_OPTS=""
57export MAKE_OPTS=""
58#export NOTEST=1
59syn3_build_automake $SRC_DIR /tmp/pkg || exit 1
60
61#strip bins and other stuff
62syn3_strip /tmp/pkg || exit 1
63
64#move development stuff and create seperate development package
65syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
66syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
67
68#make main package
69syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
70
71
Note: See TracBrowser for help on using the repository browser.