source: npl/mediabox/smpeg/smpeg.SlackBuild @ c5c522c

gcc484ntopperl-5.22
Last change on this file since c5c522c was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 1.5 KB
Line 
1#!/bin/bash
2#Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild
3#Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
4#Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
5##################################### Build dependency info:
6
7#DEP:libsdl
8#DEP:gtk+
9#DEP:svn
10
11
12
13#######Essential package info.
14#Change these if autodetection fails.
15
16#Name of the Syn-3 package that we are going to create
17NAME=`basename $0|sed 's/.SlackBuild//'`
18
19
20#Architecture that the created binaries run on.
21#Use noarch for scripts.
22ARCH=`uname -m`
23
24
25########Build and create the pacakge.
26#Uncomment the stuff that you dont want or need
27
28#Unpack source
29#(uncomment if not needed)
30#syn3_unpack $SRC_ARC || exit 1
31svn co svn://svn.icculus.org/smpeg/trunk smpeg || exit 1
32SRC_DIR=smpeg
33VER=`svnversion smpeg` || exit 1
34
35pushd $SRC_DIR || exit 1
36./autogen.sh || exit 1
37popd
38
39#build and install sourcefiles
40#./configure optiones:
41export CONFIGURE_OPTS=""
42#options for all make commands:
43export MAKE_OPTS=""
44#skip testing:
45#export NOTEST=1
46#extra optiones for the make install command, use with INSTALL_BASE for example:
47export INSTALL_OPTS=""
48syn3_build_automake $SRC_DIR /tmp/pkg || exit 1
49
50#strip bins and other stuff
51syn3_strip /tmp/pkg || exit 1
52
53#move development stuff and create seperate development package
54syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
55syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
56
57#make main package
58syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
59
60
Note: See TracBrowser for help on using the repository browser.