source: npl/monitoring/cricket/cricket.SlackBuild @ c5c522c

gcc484ntopperl-5.22
Last change on this file since c5c522c was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 639 bytes
RevLine 
[c5c522c]1#!/bin/bash
2#DEP:rrdtool
3#DEP:libart_lgpl
4#DEP:libpng
5#DEP:perlmod_SNMP_Session
6
7NAME=cricket
8VER=1.0.5
9CWD=`pwd`
10PKGTMP=/tmp/pkgtmp
11
12mkdir -p $PKGTMP &>/dev/null
13
14tar -xzf $NAME-$VER.tar.gz || exit 1
15
16cd $NAME-$VER || exit 1
17
18./configure || exit 1
19
20
21mkdir -p $PKGTMP/usr/cricket
22cp -a * $PKGTMP/usr/cricket || exit 1
23cp $CWD/subtree-sets $PKGTMP/usr/cricket || exit 1
24
25#dit is een gefixte versie omdat we een nieuwe versie
26#van perl hebben. (komt uit cvs)
27cp $CWD/snmp.pm $PKGTMP/usr/cricket/lib || exit 1
28
29cd "$PKGTMP" || exit 1
30makepkg -l y -c n $CWD/$NAME.pkg > /dev/null &&
31echo $VER > $CWD/$NAME.version &&
32arch > $CWD/$NAME.arch
33
Note: See TracBrowser for help on using the repository browser.