Last change
on this file since 105afb5 was
c5c522c,
checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago
|
initial commit, transferred from cleaned syn3 svn tree
|
-
Property mode set to
100755
|
File size:
769 bytes
|
Rev | Line | |
---|
[c5c522c] | 1 | #!/bin/bash |
---|
| 2 | #DEP:libpng |
---|
| 3 | #DEP:libart_lgpl |
---|
| 4 | #DEP:freetype2 |
---|
| 5 | #DEP:libxml2 |
---|
| 6 | #DEP:pango |
---|
| 7 | #DEP:cairo |
---|
| 8 | #DEP:groff |
---|
| 9 | #DEP:glib2 |
---|
| 10 | #DEP:pixman |
---|
| 11 | #DEP:fontconfig |
---|
| 12 | #DEP:xorg_lib |
---|
| 13 | #DEP:pthread_stubs |
---|
| 14 | #DEP:harfbuzz |
---|
| 15 | #DEP:expat |
---|
| 16 | #DEP:libffi |
---|
| 17 | #DEP:zlib |
---|
| 18 | |
---|
| 19 | NAME=rrdtool |
---|
| 20 | VER=1.5.5 |
---|
| 21 | CWD=`pwd` |
---|
| 22 | PKGTMP=/tmp/pkgtmp |
---|
| 23 | |
---|
| 24 | mkdir -p $PKGTMP &>/dev/null |
---|
| 25 | |
---|
| 26 | tar -xzf $NAME-$VER.tar.gz || exit 1 |
---|
| 27 | |
---|
| 28 | #export CFLAGS="-std=c89" |
---|
| 29 | #export CFLAGS="-fgnu89-inline" #If "multiple definition of `foo'" Also see http://gcc.gnu.org/gcc-4.3/porting_to.html |
---|
| 30 | |
---|
| 31 | |
---|
| 32 | cd $NAME-$VER |
---|
| 33 | ./configure --disable-rrdcgi --prefix=/usr --enable-perl-site-install || exit 1 |
---|
| 34 | make || exit 1 |
---|
| 35 | make DESTDIR=$PKGTMP install || exit 1 |
---|
| 36 | |
---|
| 37 | cd "$PKGTMP" || exit 1 |
---|
| 38 | makepkg -l y -c n $CWD/$NAME.pkg > /dev/null && |
---|
| 39 | echo $VER > $CWD/$NAME.version && |
---|
| 40 | arch > $CWD/$NAME.arch |
---|
| 41 | |
---|
Note: See
TracBrowser
for help on using the repository browser.