source: npl/monitoring/rrdtool/rrdtool.SlackBuild @ c5c522c

gcc484ntopperl-5.22
Last change on this file since c5c522c was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 769 bytes
Line 
1#!/bin/bash
2#DEP:libpng
3#DEP:libart_lgpl
4#DEP:freetype2
5#DEP:libxml2
6#DEP:pango
7#DEP:cairo
8#DEP:groff
9#DEP:glib2
10#DEP:pixman
11#DEP:fontconfig
12#DEP:xorg_lib
13#DEP:pthread_stubs
14#DEP:harfbuzz
15#DEP:expat
16#DEP:libffi
17#DEP:zlib
18
19NAME=rrdtool
20VER=1.5.5
21CWD=`pwd`
22PKGTMP=/tmp/pkgtmp
23
24mkdir -p $PKGTMP &>/dev/null
25
26tar -xzf $NAME-$VER.tar.gz || exit 1
27
28#export CFLAGS="-std=c89"
29#export CFLAGS="-fgnu89-inline" #If "multiple definition of `foo'" Also see http://gcc.gnu.org/gcc-4.3/porting_to.html
30
31
32cd $NAME-$VER
33./configure --disable-rrdcgi --prefix=/usr --enable-perl-site-install || exit 1
34make || exit 1
35make DESTDIR=$PKGTMP install || exit 1
36
37cd "$PKGTMP" || exit 1
38makepkg -l y -c n $CWD/$NAME.pkg > /dev/null &&
39echo $VER > $CWD/$NAME.version &&
40arch > $CWD/$NAME.arch
41
Note: See TracBrowser for help on using the repository browser.