source: npl/monitoring/smokeping/smokeping.SlackBuild @ c5c522c

gcc484ntopperl-5.22
Last change on this file since c5c522c was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 2.7 KB
Line 
1#!/bin/bash
2#Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild
3#Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
4#Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
5##################################### Build dependency info:
6
7#Strict build-dependencies
8#Our package will be automaticly rebuilded if there is a major change in a DEP package.
9#(this is recommended for most dependencys)
10##DEP:linux
11##DEP:linux_src
12##DEP:openldap
13
14#Loose build-dependencies
15#The package will be installed in the buildroot during buidling, but no automatic rebuild will occur.
16#(not recommended)
17##NEED:doxygen
18
19#######Essential package info.
20#Change these if autodetection fails.
21
22#Name of the Syn-3 package that we are going to create
23NAME=`basename $0|sed 's/.SlackBuild//'`
24
25#Archive of the sourcefiles to unpack
26SRC_ARC=`ls *.tar.* *.zip 2>/dev/null`
27
28#Version of the sourcefiles
29VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g' | sed 's/\.zip$//g'`
30
31#Architecture that the created binaries run on.
32#Use noarch for scripts.
33ARCH=`uname -m`
34
35#from this point on, exit on errors:
36set -e
37
38########Build and create the pacakge.
39#Uncomment the stuff that you dont want or need
40
41#Unpack source
42#(uncomment if not needed)
43syn3_unpack $SRC_ARC
44
45#Directory where the sourcefiles are unpacked.
46#(you might have to adjust this if autodetection fails)
47SRC_DIR=`ls -c|head -1`
48
49#apply patches
50patch -p1 -d $SRC_DIR < smokeping-mail.patch || exit 1
51
52pushd $SRC_DIR
53
54#manually SUCKY install
55mkdir -p /tmp/pkg/bin
56mkdir -p /tmp/pkg/etc
57mkdir -p /tmp/pkg/usr/lib/smokeping/doc
58mkdir -p /tmp/pkg/home/system/smokeping/data
59mkdir -p /tmp/pkg/var/www/htdocs/syn3/smokeping/cache
60mkdir -p /tmp/pkg/etc/postinst.d
61
62cp bin/smokeping.dist /tmp/pkg/bin/smokeping
63cp bin/tSmoke.dist /tmp/pkg/bin/tSmoke
64cp ../basepage.html /tmp/pkg/var/www/htdocs/syn3/smokeping/basepage.html
65cp ../syn3.png /tmp/pkg/var/www/htdocs/syn3/smokeping/
66
67cp -a lib/* /tmp/pkg/usr/lib/smokeping/
68cp etc/smokemail.dist /tmp/pkg/usr/lib/smokeping/smokemail
69cp -a doc/* /tmp/pkg/usr/lib/smokeping/doc
70
71cp ../smokeping.conf.new /tmp/pkg/home/system/smokeping
72cp ../syn3-asterisk_smokeping /tmp/pkg/home/system/smokeping
73cp ../mailtemplate /tmp/pkg/home/system/smokeping
74chmod +x /tmp/pkg/home/system/smokeping/syn3-ast*
75
76#hack paths in perl script (succcks)
77sed -i 's@/usr/pack/rrdtool-1.3.0-rp/lib/perl@/usr/lib/smokeping/@' /tmp/pkg/bin/smokeping
78
79cp ../post.smokeping /tmp/pkg/etc/postinst.d
80chmod +x /tmp/pkg/etc/postinst.d/*
81
82mkdir -p /tmp/pkg/service/smokeping
83cp ../run /tmp/pkg/service/smokeping
84chmod +x /tmp/pkg/service/smokeping/*
85
86
87popd
88
89#make main package
90syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
91
92
93
Note: See TracBrowser for help on using the repository browser.