Last change
on this file was
c5c522c,
checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago
|
initial commit, transferred from cleaned syn3 svn tree
|
-
Property mode set to
100755
|
File size:
696 bytes
|
Line | |
---|
1 | #!/bin/bash |
---|
2 | |
---|
3 | #DEP:net_snmp |
---|
4 | |
---|
5 | NAME="syn3_snmp_subagent" |
---|
6 | VERSION="1" |
---|
7 | CWD=`pwd` |
---|
8 | PKGTMP=/tmp/pkgtmp |
---|
9 | |
---|
10 | mkdir -p $PKGTMP &>/dev/null |
---|
11 | |
---|
12 | #go to the source |
---|
13 | cd subagent/ |
---|
14 | make clean |
---|
15 | make || exit 1 |
---|
16 | mkdir -p $PKGTMP/sbin |
---|
17 | strip $NAME || exit 1 |
---|
18 | cp $NAME $PKGTMP/sbin || exit 1 |
---|
19 | chmod +x $PKGTMP/sbin/* || exit 1 |
---|
20 | |
---|
21 | #service |
---|
22 | mkdir -p $PKGTMP/service/$NAME || exit 1 |
---|
23 | cp ../run $PKGTMP/service/$NAME || exit 1 |
---|
24 | chmod +x $PKGTMP/service/$NAME/run || exit 1 |
---|
25 | |
---|
26 | #Copy the MIB files to the snmp mibs directory. |
---|
27 | mkdir -p $PKGTMP/usr/share/snmp/mibs/ |
---|
28 | cp ../datux-mibs/* $PKGTMP/usr/share/snmp/mibs/ |
---|
29 | |
---|
30 | cd "$PKGTMP" || exit 1 |
---|
31 | makepkg -l y -c n $CWD/$NAME.pkg > /dev/null && |
---|
32 | echo $VER > $CWD/$NAME.version && |
---|
33 | arch > $CWD/$NAME.arch |
---|
34 | |
---|
Note: See
TracBrowser
for help on using the repository browser.