source: npl/monitoring/syn3_snmp_subagent/syn3_snmp_subagent.SlackBuild

Last change on this file was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 696 bytes
Line 
1#!/bin/bash
2
3#DEP:net_snmp
4
5NAME="syn3_snmp_subagent"
6VERSION="1"
7CWD=`pwd`
8PKGTMP=/tmp/pkgtmp
9
10mkdir -p $PKGTMP &>/dev/null
11
12#go to the source
13cd subagent/
14make clean
15make || exit 1
16mkdir -p $PKGTMP/sbin
17strip $NAME || exit 1
18cp $NAME $PKGTMP/sbin || exit 1
19chmod +x $PKGTMP/sbin/* || exit 1
20
21#service
22mkdir -p $PKGTMP/service/$NAME || exit 1
23cp ../run $PKGTMP/service/$NAME || exit 1
24chmod +x $PKGTMP/service/$NAME/run || exit 1
25
26#Copy the MIB files to the snmp mibs directory.
27mkdir -p $PKGTMP/usr/share/snmp/mibs/
28cp ../datux-mibs/* $PKGTMP/usr/share/snmp/mibs/
29
30cd "$PKGTMP" || exit 1
31makepkg -l y -c n $CWD/$NAME.pkg > /dev/null &&
32echo $VER > $CWD/$NAME.version &&
33arch > $CWD/$NAME.arch
34
Note: See TracBrowser for help on using the repository browser.