source: npl/overig/aircrack-ng/aircrack_ng.SlackBuild @ 4e011a4

gcc484perl-5.22
Last change on this file since 4e011a4 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 2.1 KB
Line 
1#!/bin/bash
2#Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild
3#Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
4#Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
5##################################### Build dependency info:
6
7#Strict build-dependencies.
8#Only use when really neccesary, this will rebuild our package if the dependencie has changed:
9##DEP:linux
10##DEP:linux_src
11
12
13#Loose build-dependencies.
14#Use this to specify the packages that are required to build our package:
15##NEED:libcairo
16##NEED:glib
17##NEED:gtk+
18##NEED:glib2
19##NEED:gtk+2
20##NEED:xorg_lib
21##NEED:xorg_proto
22
23#######Essential package info.
24#Change these if autodetection fails.
25
26#Name of the Syn-3 package that we are going to create
27NAME=`basename $0|sed 's/.SlackBuild//'`
28
29#Archive of the sourcefiles to unpack
30SRC_ARC=`ls *.tar.*`
31
32#Version of the sourcefiles
33VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g'`
34
35#Directory of the sourcefiles to build (after optional unpacking)
36SRC_DIR=aircrack-ng-$VER
37
38
39#Architecture that the created binaries run on.
40#Use noarch for scripts.
41ARCH=`arch`
42
43
44########Build and create the pacakge.
45#Uncomment the stuff that you dont want or need
46
47#Unpack source
48#(uncomment if not needed)
49syn3_unpack $SRC_ARC || exit 1
50
51#apply patches
52#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
53
54#build and install sourcefiles
55#./configure optiones:
56export CONFIGURE_OPTS=""
57#options for all make commands:
58export MAKE_OPTS=""
59#skip testing:
60#export NOTEST=1
61#extra optiones for the make install command, use with INSTALL_BASE for example:
62export INSTALL_OPTS=""
63#syn3_build_automake $SRC_DIR /tmp/pkg || exit 1
64pushd $SRC_DIR || exit 1
65make prefix=/usr || exit 1
66make prefix=/usr destdir=/tmp/pkg install || exit 1
67popd
68
69#strip bins and other stuff
70syn3_strip /tmp/pkg || exit 1
71
72#move development stuff and create seperate development package
73syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
74syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
75
76#make main package
77syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
78
79
Note: See TracBrowser for help on using the repository browser.