source: npl/overig/alsa/alsa_utils/alsa_utils.SlackBuild @ 21d4867

perl-5.22
Last change on this file since 21d4867 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 2.1 KB
Line 
1#!/bin/bash
2#Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild
3#Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
4#Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
5##################################### Build dependency info:
6
7#Strict build-dependencies.
8#Only use when really neccesary, this will rebuild our package if the dependencie has changed:
9##DEP:linux
10##DEP:linux_src
11#DEP:alsa_lib
12
13#Loose build-dependencies.
14#Use this to specify the packages that are required to build our package:
15##NEED:libcairo
16##NEED:glib
17##NEED:gtk+
18##NEED:glib2
19##NEED:gtk+2
20##NEED:xorg_lib
21##NEED:xorg_proto
22#DEP:ncurses
23
24#######Essential package info.
25#Change these if autodetection fails.
26
27#Name of the Syn-3 package that we are going to create
28NAME=`basename $0|sed 's/.SlackBuild//'`
29
30#Archive of the sourcefiles to unpack
31SRC_ARC=`ls *.tar.*`
32
33#Version of the sourcefiles
34VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g'`
35
36#Directory of the sourcefiles to build (after optional unpacking)
37SRC_DIR=`echo $SRC_ARC| sed 's/\.tar\..*$//g'`
38
39#Architecture that the created binaries run on.
40#Use noarch for scripts.
41ARCH=`arch`
42
43
44########Build and create the pacakge.
45#Uncomment the stuff that you dont want or need
46
47#Unpack source
48#(uncomment if not needed)
49syn3_unpack $SRC_ARC || exit 1
50
51#apply patches
52#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
53
54#build and install sourcefiles
55#(use one of the other syn3_build_* scripts when needed)
56export CONFIGURE_OPTS="--disable-xmlto"
57export MAKE_OPTS=""
58#export NOTEST=1
59syn3_build_automake $SRC_DIR /tmp/pkg || exit 1
60
61#add slackware rc script
62mkdir -p /tmp/pkg/etc/rc.d || exit 1
63cp rc.alsa /tmp/pkg/etc/rc.d || exit 1
64chmod +x /tmp/pkg/etc/rc.d/rc.alsa || exit 1
65
66#strip bins and other stuff
67syn3_strip /tmp/pkg || exit 1
68
69#move development stuff and create seperate development package
70syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
71syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
72
73#make main package
74syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
75
76
Note: See TracBrowser for help on using the repository browser.