1 | #!/bin/bash |
---|
2 | #Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild |
---|
3 | #Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven. |
---|
4 | #Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden. |
---|
5 | ##################################### Build dependency info: |
---|
6 | |
---|
7 | #Strict build-dependencies. |
---|
8 | #Only use when really neccesary, this will rebuild our package if the dependencie has changed: |
---|
9 | ##DEP:linux |
---|
10 | ##DEP:linux_src |
---|
11 | |
---|
12 | #Loose build-dependencies. |
---|
13 | #Use this to specify the packages that are required to build our package: |
---|
14 | ##NEED:libcairo |
---|
15 | ##NEED:glib |
---|
16 | ##NEED:gtk+ |
---|
17 | ##NEED:glib2 |
---|
18 | ##NEED:gtk+2 |
---|
19 | ##NEED:xorg_lib |
---|
20 | ##NEED:xorg_proto |
---|
21 | #DEP:net_snmp |
---|
22 | |
---|
23 | #######Essential package info. |
---|
24 | #Change these if autodetection fails. |
---|
25 | |
---|
26 | #Name of the Syn-3 package that we are going to create |
---|
27 | NAME=`basename $0|sed 's/.SlackBuild//'` |
---|
28 | |
---|
29 | #Archive of the sourcefiles to unpack |
---|
30 | SRC_ARC=`ls *.tar.*` |
---|
31 | |
---|
32 | #Version of the sourcefiles |
---|
33 | VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g'` |
---|
34 | |
---|
35 | #Directory of the sourcefiles to build (after optional unpacking) |
---|
36 | SRC_DIR=`echo $SRC_ARC| sed 's/\.tar\..*$//g'` |
---|
37 | |
---|
38 | #Architecture that the created binaries run on. |
---|
39 | #Use noarch for scripts. |
---|
40 | ARCH=`arch` |
---|
41 | |
---|
42 | |
---|
43 | ########Build and create the pacakge. |
---|
44 | #Uncomment the stuff that you dont want or need |
---|
45 | |
---|
46 | #Unpack source |
---|
47 | #(uncomment if not needed) |
---|
48 | syn3_unpack $SRC_ARC || exit 1 |
---|
49 | |
---|
50 | #apply patches |
---|
51 | #patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1 |
---|
52 | |
---|
53 | #build and install sourcefiles |
---|
54 | #./configure optiones: |
---|
55 | export CONFIGURE_OPTS="--enable-usb --enable-snmp --enable-net-snmp" |
---|
56 | #options for all make commands: |
---|
57 | export MAKE_OPTS="" |
---|
58 | #skip testing: |
---|
59 | #export NOTEST=1 |
---|
60 | #extra optiones for the make install command, use with INSTALL_BASE for example: |
---|
61 | export INSTALL_OPTS="" |
---|
62 | syn3_build_automake $SRC_DIR /tmp/pkg || exit 1 |
---|
63 | |
---|
64 | #strip bins and other stuff |
---|
65 | syn3_strip /tmp/pkg || exit 1 |
---|
66 | |
---|
67 | #syn3-apccheck script: |
---|
68 | mkdir /tmp/pkg/sbin |
---|
69 | cp syn3-apccheck /tmp/pkg/sbin |
---|
70 | chmod +x /tmp/pkg/sbin/syn3-apccheck || exit 1 |
---|
71 | |
---|
72 | #replace configuration and scripts with syn3 stuff: |
---|
73 | rm /tmp/pkg/etc/* |
---|
74 | |
---|
75 | mkdir -p /tmp/pkg/service/apcupsd |
---|
76 | cp run /tmp/pkg/service/apcupsd |
---|
77 | chmod +x /tmp/pkg/service/apcupsd/run || exit 1 |
---|
78 | |
---|
79 | mkdir /tmp/pkg/etc |
---|
80 | cp etc/* /tmp/pkg/etc || exit 1 |
---|
81 | chmod +x /tmp/pkg/etc/* || exit 1 |
---|
82 | |
---|
83 | #move development stuff and create seperate development package |
---|
84 | syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1 |
---|
85 | syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1 |
---|
86 | |
---|
87 | #make main package |
---|
88 | syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1 |
---|
89 | |
---|
90 | |
---|