source: npl/overig/apr/apr.SlackBuild.orig @ c5c522c

gcc484ntopperl-5.22
Last change on this file since c5c522c was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 3.3 KB
Line 
1#!/bin/sh
2
3# Copyright 2008, 2009, 2010, 2011  Patrick J. Volkerding, Sebeka, Minnesota, USA
4# All rights reserved.
5#
6# Redistribution and use of this script, with or without modification, is
7# permitted provided that the following conditions are met:
8#
9# 1. Redistributions of this script must retain the above copyright
10#    notice, this list of conditions and the following disclaimer.
11#
12#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
13#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
14#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
15#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
16#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
17#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
18#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
19#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
20#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
21#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
22
23
24VERSION=${VERSION:-$(echo apr-*.tar.bz2 | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
25BUILD=${BUILD:-1}
26
27# Automatically determine the architecture we're building on:
28if [ -z "$ARCH" ]; then
29  case "$( uname -m )" in
30    i?86) export ARCH=i586 ;;
31    arm*) export ARCH=arm ;;
32    # Unless $ARCH is already set, use uname -m for all other archs:
33       *) export ARCH=$( uname -m ) ;;
34  esac
35fi
36
37NUMJOBS=${NUMJOBS:-" -j7 "}
38
39if [ "$ARCH" = "i586" ]; then
40  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
41  LIBDIRSUFFIX=""
42elif [ "$ARCH" = "s390" ]; then
43  SLKCFLAGS="-O2"
44  LIBDIRSUFFIX=""
45elif [ "$ARCH" = "x86_64" ]; then
46  SLKCFLAGS="-O2 -fPIC"
47  LIBDIRSUFFIX="64"
48else
49  SLKCFLAGS="-O2"
50  LIBDIRSUFFIX=""
51fi
52
53CWD=$(pwd)
54TMP=${TMP:-/tmp}
55PKG=$TMP/package-apr
56
57rm -rf $PKG
58mkdir -p $TMP $PKG
59
60cd $TMP
61rm -rf apr-$VERSION
62tar xvf $CWD/apr-$VERSION.tar.bz2 || exit 1
63cd apr-$VERSION
64
65chown -R root:root .
66find . \
67  \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
68  -exec chmod 755 {} \; -o \
69  \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
70  -exec chmod 644 {} \;
71
72CFLAGS="$SLKCFLAGS" \
73./configure \
74  --prefix=/usr \
75  --libdir=/usr/lib${LIBDIRSUFFIX} \
76  --with-installbuilddir=/usr/lib${LIBDIRSUFFIX}/apr-${VERSION}/build-1 \
77  --disable-static \
78  --with-devrandom=/dev/urandom \
79  --build=$ARCH-slackware-linux
80
81make $NUMJOBS || make || exit 1
82make dox || exit 1
83make install DESTDIR=$PKG || exit 1
84
85find $PKG | xargs file | grep -e "executable" -e "shared object" \
86  | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
87
88mkdir -p $PKG/usr/doc/apr-$VERSION
89cp -a \
90  LICENSE NOTICE README* \
91  $PKG/usr/doc/apr-$VERSION
92
93# If there's a CHANGES file, installing at least part of the recent history
94# is useful, but don't let it get totally out of control:
95if [ -r CHANGES ]; then
96  DOCSDIR=$(echo $PKG/usr/doc/*-$VERSION)
97  cat CHANGES | head -n 1000 > $DOCSDIR/CHANGES
98  touch -r CHANGES $DOCSDIR/CHANGES
99fi
100
101# This just seems like way too much stuff...
102#mv docs/dox/html $PKG/usr/doc/apr-$VERSION
103
104mkdir -p $PKG/install
105cat $CWD/slack-desc > $PKG/install/slack-desc
106
107# Build the package:
108cd $PKG
109/sbin/makepkg -l y -c n $TMP/apr-$VERSION-$ARCH-$BUILD.txz
110
Note: See TracBrowser for help on using the repository browser.