[c5c522c] | 1 | #!/bin/sh |
---|
| 2 | |
---|
| 3 | # Copyright 2008, 2009, 2010, 2011, 2012, 2013 Patrick J. Volkerding, Sebeka, Minnesota, USA |
---|
| 4 | # All rights reserved. |
---|
| 5 | # |
---|
| 6 | # Redistribution and use of this script, with or without modification, is |
---|
| 7 | # permitted provided that the following conditions are met: |
---|
| 8 | # |
---|
| 9 | # 1. Redistributions of this script must retain the above copyright |
---|
| 10 | # notice, this list of conditions and the following disclaimer. |
---|
| 11 | # |
---|
| 12 | # THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED |
---|
| 13 | # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF |
---|
| 14 | # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO |
---|
| 15 | # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, |
---|
| 16 | # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, |
---|
| 17 | # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; |
---|
| 18 | # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, |
---|
| 19 | # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR |
---|
| 20 | # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF |
---|
| 21 | # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. |
---|
| 22 | |
---|
| 23 | |
---|
| 24 | VERSION=${VERSION:-$(echo apr-util-*.tar.bz2 | rev | cut -f 3- -d . | cut -f 1 -d - | rev)} |
---|
| 25 | BUILD=${BUILD:-2} |
---|
| 26 | |
---|
| 27 | # Automatically determine the architecture we're building on: |
---|
| 28 | if [ -z "$ARCH" ]; then |
---|
| 29 | case "$( uname -m )" in |
---|
| 30 | i?86) export ARCH=i586 ;; |
---|
| 31 | arm*) export ARCH=arm ;; |
---|
| 32 | # Unless $ARCH is already set, use uname -m for all other archs: |
---|
| 33 | *) export ARCH=$( uname -m ) ;; |
---|
| 34 | esac |
---|
| 35 | fi |
---|
| 36 | |
---|
| 37 | NUMJOBS=${NUMJOBS:-" -j7 "} |
---|
| 38 | |
---|
| 39 | if [ "$ARCH" = "i586" ]; then |
---|
| 40 | SLKCFLAGS="-O2 -march=i586 -mtune=i686" |
---|
| 41 | LIBDIRSUFFIX="" |
---|
| 42 | elif [ "$ARCH" = "s390" ]; then |
---|
| 43 | SLKCFLAGS="-O2" |
---|
| 44 | LIBDIRSUFFIX="" |
---|
| 45 | elif [ "$ARCH" = "x86_64" ]; then |
---|
| 46 | SLKCFLAGS="-O2 -fPIC" |
---|
| 47 | LIBDIRSUFFIX="64" |
---|
| 48 | else |
---|
| 49 | SLKCFLAGS="-O2" |
---|
| 50 | LIBDIRSUFFIX="" |
---|
| 51 | fi |
---|
| 52 | |
---|
| 53 | CWD=$(pwd) |
---|
| 54 | TMP=${TMP:-/tmp} |
---|
| 55 | PKG=$TMP/package-apr-util |
---|
| 56 | |
---|
| 57 | rm -rf $PKG |
---|
| 58 | mkdir -p $TMP $PKG |
---|
| 59 | |
---|
| 60 | cd $TMP |
---|
| 61 | rm -rf apr-util-$VERSION |
---|
| 62 | tar xvf $CWD/apr-util-$VERSION.tar.bz2 || exit 1 |
---|
| 63 | cd apr-util-$VERSION |
---|
| 64 | |
---|
| 65 | # For now, this isn't working with svn (here, anyway) and is probably |
---|
| 66 | # more trouble than it's worth. Could be a grey area in regards to |
---|
| 67 | # licensing, too -- the Apache people say it's fine for third parties |
---|
| 68 | # to link this and distribute the result, but there are usually some |
---|
| 69 | # differing opinions when it comes to this sort of thing... |
---|
| 70 | #( cd dbd ; lftpget http://apache.webthing.com/svn/apache/apr/apr_dbd_mysql.c ) |
---|
| 71 | # --with-mysql=/usr \ |
---|
| 72 | # |
---|
| 73 | |
---|
| 74 | chown -R root:root . |
---|
| 75 | find . \ |
---|
| 76 | \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \ |
---|
| 77 | -exec chmod 755 {} \; -o \ |
---|
| 78 | \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \ |
---|
| 79 | -exec chmod 644 {} \; |
---|
| 80 | |
---|
| 81 | CFLAGS="$SLKCFLAGS" \ |
---|
| 82 | ./configure \ |
---|
| 83 | --prefix=/usr \ |
---|
| 84 | --libdir=/usr/lib${LIBDIRSUFFIX} \ |
---|
| 85 | --with-apr=/usr \ |
---|
| 86 | --with-dbm=db44 \ |
---|
| 87 | --with-berkeley-db \ |
---|
| 88 | --disable-util-dso \ |
---|
| 89 | --without-gdbm \ |
---|
| 90 | --with-ldap \ |
---|
| 91 | --disable-static \ |
---|
| 92 | --without-sqlite2 \ |
---|
| 93 | --build=$ARCH-slackware-linux |
---|
| 94 | |
---|
| 95 | make $NUMJOBS || make || exit 1 |
---|
| 96 | make dox || exit 1 |
---|
| 97 | make install DESTDIR=$PKG |
---|
| 98 | |
---|
| 99 | find $PKG | xargs file | grep -e "executable" -e "shared object" \ |
---|
| 100 | | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null |
---|
| 101 | |
---|
| 102 | mkdir -p $PKG/usr/doc/apr-util-$VERSION |
---|
| 103 | cp -a \ |
---|
| 104 | INSTALL.MySQL LICENSE NOTICE \ |
---|
| 105 | $PKG/usr/doc/apr-util-$VERSION |
---|
| 106 | |
---|
| 107 | # If there's a CHANGES file, installing at least part of the recent history |
---|
| 108 | # is useful, but don't let it get totally out of control: |
---|
| 109 | if [ -r CHANGES ]; then |
---|
| 110 | DOCSDIR=$(echo $PKG/usr/doc/*-$VERSION) |
---|
| 111 | cat CHANGES | head -n 1000 > $DOCSDIR/CHANGES |
---|
| 112 | touch -r CHANGES $DOCSDIR/CHANGES |
---|
| 113 | fi |
---|
| 114 | |
---|
| 115 | # This just seems like way too much stuff... |
---|
| 116 | #mv docs/dox/html $PKG/usr/doc/apr-util-$VERSION |
---|
| 117 | |
---|
| 118 | mkdir -p $PKG/install |
---|
| 119 | cat $CWD/slack-desc > $PKG/install/slack-desc |
---|
| 120 | |
---|
| 121 | # Build the package: |
---|
| 122 | cd $PKG |
---|
| 123 | /sbin/makepkg -l y -c n $TMP/apr-util-$VERSION-$ARCH-$BUILD.txz |
---|
| 124 | |
---|