source: npl/overig/archivetools/lzip/lzip.SlackBuild.orig @ 250d444

gcc484perl-5.22
Last change on this file since 250d444 was 250d444, checked in by Edwin Eefting <edwin@datux.nl>, 7 years ago

lzip

  • Property mode set to 100755
File size: 4.2 KB
Line 
1#!/bin/sh
2
3# Copyright 2014, 2017, 2018  Patrick J. Volkerding, Sebeka, Minnesota, USA
4# All rights reserved.
5#
6# Redistribution and use of this script, with or without modification, is
7# permitted provided that the following conditions are met:
8#
9# 1. Redistributions of this script must retain the above copyright
10#    notice, this list of conditions and the following disclaimer.
11#
12#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
13#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
14#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
15#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
16#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
17#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
18#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
19#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
20#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
21#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
22
23
24PKGNAM=lzip
25VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
26BUILD=${BUILD:-2}
27
28# Automatically determine the architecture we're building on:
29if [ -z "$ARCH" ]; then
30  case "$(uname -m)" in
31    i?86) ARCH=i586 ;;
32    arm*) readelf /usr/bin/file -A | egrep -q "Tag_CPU.*[4,5]" && ARCH=arm || ARCH=armv7hl ;;
33    # Unless $ARCH is already set, use uname -m for all other archs:
34    *) ARCH=$(uname -m) ;;
35  esac
36  export ARCH
37fi
38
39NUMJOBS=${NUMJOBS:-" -j7 "}
40
41if [ "$ARCH" = "i386" ]; then
42  SLKCFLAGS="-O2 -march=i386 -mcpu=i686"
43  LIBDIRSUFFIX=""
44elif [ "$ARCH" = "i486" ]; then
45  SLKCFLAGS="-O2 -march=i486 -mtune=i686"
46  LIBDIRSUFFIX=""
47elif [ "$ARCH" = "i586" ]; then
48  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
49  LIBDIRSUFFIX=""
50elif [ "$ARCH" = "i686" ]; then
51  SLKCFLAGS="-O2 -march=i686"
52  LIBDIRSUFFIX=""
53elif [ "$ARCH" = "s390" ]; then
54  SLKCFLAGS="-O2"
55  LIBDIRSUFFIX=""
56elif [ "$ARCH" = "x86_64" ]; then
57  SLKCFLAGS="-O2 -fPIC"
58  LIBDIRSUFFIX="64"
59elif [ "$ARCH" = "armv7hl" ]; then
60  SLKCFLAGS="-O3 -march=armv7-a -mfpu=vfpv3-d16"
61  LIBDIRSUFFIX=""
62else
63  SLKCFLAGS="-O2"
64  LIBDIRSUFFIX=""
65fi
66
67CWD=$(pwd)
68TMP=${TMP:-/tmp}
69PKG=$TMP/package-$PKGNAM
70
71rm -rf $PKG
72mkdir -p $TMP $PKG
73
74cd $TMP
75rm -rf $PKGNAM-$VERSION
76tar xvf $CWD/$PKGNAM-$VERSION.tar.?z || exit 1
77cd $PKGNAM-$VERSION || exit 1
78
79chown -R root:root .
80find . \
81  \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
82  -exec chmod 755 {} \; -o \
83  \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
84  -exec chmod 644 {} \;
85
86# Configure:
87./configure \
88  CXXFLAGS="$SLKCFLAGS" \
89  --prefix=/usr \
90  --sysconfdir=/etc \
91  --libdir=/usr/lib${LIBDIRSUFFIX} \
92  --mandir=/usr/man \
93  --infodir=/usr/info \
94  --disable-static \
95  --build=$ARCH-slackware-linux || exit 1
96
97# Build and install:
98make $NUMJOBS || make || exit 1
99make install DESTDIR=$PKG || exit 1
100
101# Strip binaries:
102( cd $PKG
103  find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
104  find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
105) || true
106
107# Add a documentation directory:
108mkdir -p $PKG/usr/doc/${PKGNAM}-$VERSION
109cp -a \
110  AUTHORS COPYING* INSTALL NEWS README* THANKS TODO \
111  $PKG/usr/doc/${PKGNAM}-$VERSION || true
112
113# Compress manual pages:
114find $PKG/usr/man -type f -exec gzip -9 {} \;
115for i in $( find $PKG/usr/man -type l ) ; do
116  ln -s $( readlink $i ).gz $i.gz
117  rm $i
118done
119
120# Compress info files, if any:
121if [ -d $PKG/usr/info ]; then
122  ( cd $PKG/usr/info
123    rm -f dir
124    gzip -9 *
125  )
126fi
127
128# If there's a ChangeLog, installing at least part of the recent history
129# is useful, but don't let it get totally out of control:
130if [ -r ChangeLog ]; then
131  DOCSDIR=$(echo $PKG/usr/doc/${PKGNAM}-$VERSION)
132  cat ChangeLog | head -n 1000 > $DOCSDIR/ChangeLog
133  touch -r ChangeLog $DOCSDIR/ChangeLog
134fi
135
136
137mkdir -p $PKG/install
138#zcat $CWD/doinst.sh.gz > $PKG/install/doinst.sh
139cat $CWD/slack-desc > $PKG/install/slack-desc
140
141cd $PKG
142/sbin/makepkg -l y -c n $TMP/$PKGNAM-$VERSION-$ARCH-$BUILD.txz
Note: See TracBrowser for help on using the repository browser.