source: npl/overig/archivetools/lzo/lzo.SlackBuild

Last change on this file was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 549 bytes
Line 
1#!/bin/bash
2ROOT=`pwd`
3PACKAGE=lzo
4VERSION=1.08
5PKGROOT=/tmp/lzo
6
7
8mkdir $PKGROOT -p
9tar -xzf $PACKAGE-$VERSION.tar.gz ||exit 1
10cd $PACKAGE-$VERSION ||exit 1
11#patch -p1 <../pax-3.3-gcc.patch
12##patch -p1 <../pax-3.3-doc.patch
13#patch -p1 <../pax-3.3-modifyWarn.patch
14#patch -p1 <../pax-3.3-bzip2.patch
15
16./configure --prefix=/usr ||exit 1
17make ||exit 1
18make install DESTDIR=$PKGROOT ||exit 1
19cd $PKGROOT ||exit 1
20makepkg -l y -c n $ROOT/$PACKAGE.pkg > /dev/null &&
21echo $VERSION > $ROOT/$PACKAGE.version &&
22arch > $ROOT/$PACKAGE.arch &&
23
24rm -r $PKGROOT
Note: See TracBrowser for help on using the repository browser.