source: npl/overig/archivetools/lzop/lzop.SlackBuild @ c5c522c

gcc484ntopperl-5.22
Last change on this file since c5c522c was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 560 bytes
Line 
1#!/bin/bash
2#DEP:lzo
3ROOT=`pwd`
4PACKAGE=lzop
5VERSION=1.01
6PKGROOT=/tmp/lzop
7
8
9mkdir $PKGROOT -p
10tar -xzf $PACKAGE-$VERSION.tar.gz ||exit 1
11cd $PACKAGE-$VERSION ||exit 1
12#patch -p1 <../pax-3.3-gcc.patch
13##patch -p1 <../pax-3.3-doc.patch
14#patch -p1 <../pax-3.3-modifyWarn.patch
15#patch -p1 <../pax-3.3-bzip2.patch
16
17./configure --prefix=/usr ||exit 1
18make ||exit 1
19make install DESTDIR=$PKGROOT ||exit 1
20cd $PKGROOT ||exit 1
21makepkg -l y -c n $ROOT/$PACKAGE.pkg > /dev/null &&
22echo $VERSION > $ROOT/$PACKAGE.version &&
23arch > $ROOT/$PACKAGE.arch &&
24
25rm -r $PKGROOT
Note: See TracBrowser for help on using the repository browser.