gcc484perl-5.22
Last change
on this file since cd8630b was
c5c522c,
checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago
|
initial commit, transferred from cleaned syn3 svn tree
|
-
Property mode set to
100755
|
File size:
1.0 KB
|
Rev | Line | |
---|
[c5c522c] | 1 | #!/bin/bash |
---|
| 2 | #NEED:xz |
---|
| 3 | #DEP:acl |
---|
| 4 | |
---|
| 5 | ROOT=`pwd` |
---|
| 6 | PACKAGE=tar |
---|
| 7 | VERSION=1.27.1 |
---|
| 8 | PKGROOT=/tmp/tar |
---|
| 9 | |
---|
| 10 | mkdir $PKGROOT -p |
---|
| 11 | tar -xzf $PACKAGE-$VERSION.tar.gz ||exit 1 |
---|
| 12 | cd $PACKAGE-$VERSION ||exit 1 |
---|
| 13 | |
---|
| 14 | #export CFLAGS="-std=c89" |
---|
| 15 | export CFLAGS="-fgnu89-inline" #If "multiple definition of `foo'" Also see http://gcc.gnu.org/gcc-4.3/porting_to.html |
---|
| 16 | FORCE_UNSAFE_CONFIGURE=1 ./configure --prefix=/usr --bindir=/bin ||exit 1 |
---|
| 17 | make ||exit 1 |
---|
| 18 | make install DESTDIR=$PKGROOT ||exit 1 |
---|
| 19 | |
---|
| 20 | mkdir -p $PKGROOT/usr/bin |
---|
| 21 | ln -s /bin/tar $PKGROOT/usr/bin/tar || exit 1 |
---|
| 22 | |
---|
| 23 | #speciale tar voor pkgtools nodig |
---|
| 24 | cp $ROOT/tar-1.13 $PKGROOT/bin || exit 1 |
---|
| 25 | chmod +x $PKGROOT/bin/tar-1.13 || exit 1 |
---|
| 26 | |
---|
| 27 | cd $PKGROOT ||exit 1 |
---|
| 28 | # Strip binaries: |
---|
| 29 | ( cd $PKGROOT |
---|
| 30 | find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null |
---|
| 31 | find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip -g 2> /dev/null |
---|
| 32 | ) |
---|
| 33 | |
---|
| 34 | makepkg -l y -c n $ROOT/$PACKAGE.pkg > /dev/null && |
---|
| 35 | echo $VERSION > $ROOT/$PACKAGE.version && |
---|
| 36 | arch > $ROOT/$PACKAGE.arch |
---|
Note: See
TracBrowser
for help on using the repository browser.