source: npl/overig/archivetools/unrar/unrar.SlackBuild @ c5c522c

gcc484ntopperl-5.22
Last change on this file since c5c522c was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 423 bytes
Line 
1#!/bin/bash
2ROOT=`pwd`
3PACKAGE=unrar
4VERSION=5.4.5
5PKGROOT=/tmp/unrar
6
7
8mkdir $PKGROOT -p
9tar -xzf unrarsrc-$VERSION.tar.gz ||exit 1
10cd unrar ||exit 1
11
12
13make  || exit 1
14
15strip unrar
16mkdir -p $PKGROOT/usr/bin
17cp unrar $PKGROOT/usr/bin || exit 1
18chmod +x $PKGROOT/usr/bin/unrar
19
20cd $PKGROOT || exit 1
21makepkg -l y -c n $ROOT/$PACKAGE.pkg > /dev/null &&
22echo $VERSION > $ROOT/$PACKAGE.version &&
23arch > $ROOT/$PACKAGE.arch
24
Note: See TracBrowser for help on using the repository browser.