source: npl/overig/autoconf/autoconf.SlackBuild @ ffaaf60

Last change on this file since ffaaf60 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 3.2 KB
RevLine 
[c5c522c]1#!/bin/sh
2
3# Copyright 2005-2010  Patrick J. Volkerding, Sebeka, Minnesota, USA
4# All rights reserved.
5#
6# Redistribution and use of this script, with or without modification, is
7# permitted provided that the following conditions are met:
8#
9# 1. Redistributions of this script must retain the above copyright
10#    notice, this list of conditions and the following disclaimer.
11#
12#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
13#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
14#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
15#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
16#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
17#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
18#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
19#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
20#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
21#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
22
23
24PKGNAM=autoconf
25VERSION=${VERSION:-$(echo $PKGNAM-*.tar.xz | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
26BUILD=${BUILD:-1}
27
28NUMJOBS=${NUMJOBS:-" -j7 "}
29
30# Note: the package is _built_ as 'noarch'
31
32# Automatically determine the architecture we're building on:
33if [ -z "$ARCH" ]; then
34  case "$( uname -m )" in
35    i?86) export ARCH=i486 ;;
36    arm*) export ARCH=arm ;;
37    # Unless $ARCH is already set, use uname -m for all other archs:
38       *) export ARCH=$( uname -m ) ;;
39  esac
40fi
41
42CWD=$(pwd)
43TMP=${TMP:-/tmp}
44PKG=$TMP/package-autoconf
45
46rm -rf $PKG
47mkdir -p $TMP $PKG
48
49cd $TMP
50rm -rf autoconf-$VERSION
51tar xvf $CWD/autoconf-$VERSION.tar.xz || exit 1
52cd autoconf-$VERSION
53chown -R root:root .
54find . \
55  \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
56  -exec chmod 755 {} \; -o \
57  \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
58  -exec chmod 644 {} \;
59
60./configure \
61  --prefix=/usr \
62  --infodir=/usr/info \
63  --mandir=/usr/man \
64  --build=$ARCH-slackware-linux || exit 1
65
66make $NUMJOBS || make || exit 1
67make install DESTDIR=$PKG || exit 1
68
69rm -f $PKG/usr/info/dir
70gzip -9 $PKG/usr/info/*
71gzip -9 $PKG/usr/man/man1/*.?
72
73mkdir -p $PKG/usr/doc/autoconf-$VERSION
74cp -a \
75  AUTHORS BUGS COPYING* NEWS README* THANKS TODO \
76  $PKG/usr/doc/autoconf-$VERSION
77
78# If there's a ChangeLog, installing at least part of the recent history
79# is useful, but don't let it get totally out of control:
80if [ -r ChangeLog ]; then
81  DOCSDIR=$(echo $PKG/usr/doc/${PKGNAM}-$VERSION)
82  cat ChangeLog | head -n 1000 > $DOCSDIR/ChangeLog
83  touch -r ChangeLog $DOCSDIR/ChangeLog
84fi
85
86mkdir -p $PKG/install
87zcat $CWD/doinst.sh.gz > $PKG/install/doinst.sh
88cat $CWD/slack-desc > $PKG/install/slack-desc
89
90cd $PKG
91/sbin/makepkg -l y -c n $TMP/autoconf-$VERSION-noarch-$BUILD.txz
92
93
94############ make syn3 packages
95cd $CWD
96for PKG in /tmp/package-*; do
97        NAME=`echo $PKG| sed 's/.*package-//'| sed 's/-/_/'`
98
99        #seperate dev-package
100        syn3_move_dev $PKG $PKG""_dev
101        syn3_makepkg $PKG""_dev $NAME""_dev $VERSION $ARCH || exit 1
102
103        #make main package
104        syn3_makepkg $PKG $NAME $VERSION $ARCH || exit 1
105done
Note: See TracBrowser for help on using the repository browser.