source: npl/overig/bacula/bacula.SlackBuild @ 5160d62

perl-5.22
Last change on this file since 5160d62 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 2.8 KB
Line 
1#!/bin/bash
2#Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild
3#Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
4#Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
5##################################### Build dependency info:
6
7#DEP:openssl
8#DEP:sqlite
9#DEP:attr
10#DEP:acl
11
12#Loose build-dependencies
13#The package will be installed in the buildroot during buidling, but no automatic rebuild will occur.
14#(not recommended)
15##NEED:doxygen
16
17#######Essential package info.
18#Change these if autodetection fails.
19
20#Name of the Syn-3 package that we are going to create
21NAME=`basename $0|sed 's/.SlackBuild//'`
22
23#Archive of the sourcefiles to unpack
24SRC_ARC=`ls *.tar.* *.zip 2>/dev/null`
25
26#Version of the sourcefiles
27VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g' | sed 's/\.zip$//g'`
28
29#Architecture that the created binaries run on.
30#Use noarch for scripts.
31ARCH=`uname -m`
32
33#from this point on, exit on errors:
34set -e
35
36########Build and create the pacakge.
37#Uncomment the stuff that you dont want or need
38
39#Unpack source
40#(uncomment if not needed)
41syn3_unpack $SRC_ARC
42
43#Directory where the sourcefiles are unpacked.
44#(you might have to adjust this if autodetection fails)
45SRC_DIR=`ls -c|head -1`
46
47#apply patches
48#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
49
50pushd $SRC_DIR
51
52#AUTOMAKE: Configure
53#Some usefull stuff you sometimes need to set:
54#export LDFLAGS="-L/usr/X11/lib/ -L/usr/lib/mysql/"
55#export LD_LIBRARY_PATH=/usr/lib/mysql
56#export VPATH=$LD_LIBRARY_PATH
57MAKE_OPTS=""
58CFLAGS="-g -O2"
59./configure --prefix=/usr \
60        --with-scriptdir=/usr/bin \
61        --localstatedir=/var \
62        --with-working-dir=/home/system/bacula \
63        --sysconfdir=/etc/bacula \
64        --with-sqlite3 \
65        --enable-lockmgr \
66        --with-pid-dir=/var/run || exit 1
67
68#AUTOMAKE: Compile
69make $MAKE_OPTS || exit 1
70
71#AUTOMAKE: Test (optional)
72if grep ^test: Makefile; then
73        make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1
74        make $MAKE_OPTS test || exit 1
75elif grep ^check: Makefile; then
76        make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1
77        make $MAKE_OPTS check || exit 1
78fi
79
80#AUTOMAKE: Install
81mkdir -p /tmp/pkg &>/dev/null
82make pkgconfigdir=/usr/lib/pkgconfig install_prefix=/tmp/pkg DESTDIR=/tmp/pkg INSTALL_ROOT=/tmp/pkg install_root=/tmp/pkg $MAKE_OPTS install || exit 1
83popd
84
85#clean scripts that are not needed
86rm /tmp/pkg/usr/bin/startmysql
87rm /tmp/pkg/usr/bin/stopmysql
88
89#strip bins and other stuff
90syn3_strip /tmp/pkg || exit 1
91
92#move development stuff and create seperate development package
93syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
94syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
95
96
97#remove default configuration. its in the bacula_conf package
98rm -r /tmp/pkg/etc/bacula || exit 1
99
100#make main package
101syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
102
103
104
Note: See TracBrowser for help on using the repository browser.