source: npl/overig/clucene/clucene.SlackBuild @ 34a7c56

perl-5.22
Last change on this file since 34a7c56 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 1.9 KB
Line 
1#!/bin/bash
2#Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild
3#Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
4#Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
5##################################### Build dependency info:
6
7#Strict build-dependencies.
8#Only use when really neccesary, this will rebuild our package if the dependencie has changed:
9###DEP:linux_src
10
11#Loose build-dependencies.
12#Use this to specify the packages that are required to build our package:
13
14#######Essential package info.
15#Change these if autodetection fails.
16
17#Name of the Syn-3 package that we are going to create
18NAME=`basename $0|sed 's/.SlackBuild//'`
19
20#Archive of the sourcefiles to unpack
21SRC_ARC=`ls *.tar.*`
22
23#Version of the sourcefiles
24VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g'`
25
26#Directory of the sourcefiles to build (after optional unpacking)
27SRC_DIR="clucene-core-0.9.21"
28SRC_DIR="clucene-core-0.9.21b"
29
30#Architecture that the created binaries run on.
31#Use noarch for scripts.
32ARCH=`uname -m`
33
34
35########Build and create the pacakge.
36#Uncomment the stuff that you dont want or need
37
38#Unpack source
39#(uncomment if not needed)
40syn3_unpack $SRC_ARC || exit 1
41
42#apply patches
43#patch -p1 -d $SRC_DIR < clucene-0.9.21b.patch || exit 1
44
45#build and install sourcefiles
46#./configure optiones:
47export CONFIGURE_OPTS=""
48#options for all make commands:
49export MAKE_OPTS="-j1"
50#skip testing:
51#export NOTEST=1
52#extra optiones for the make install command, use with INSTALL_BASE for example:
53export INSTALL_OPTS=""
54syn3_build_automake $SRC_DIR /tmp/pkg || exit 1
55
56#strip bins and other stuff
57syn3_strip /tmp/pkg || exit 1
58
59#move development stuff and create seperate development package
60syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
61syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
62
63#make main package
64syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
65
66
Note: See TracBrowser for help on using the repository browser.