source: npl/overig/cmake/cmake.SlackBuild.orig

Last change on this file was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 4.0 KB
Line 
1#!/bin/sh
2
3# Copyright 2008, 2009, 2010, 2011, 2013, 2015  Patrick J. Volkerding, Sebeka, Minnesota, USA
4# All rights reserved.
5#
6# Redistribution and use of this script, with or without modification, is
7# permitted provided that the following conditions are met:
8#
9# 1. Redistributions of this script must retain the above copyright
10#    notice, this list of conditions and the following disclaimer.
11#
12#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
13#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
14#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
15#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
16#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
17#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
18#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
19#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
20#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
21#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
22
23PKGNAM=cmake
24VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z* | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
25BUILD=${BUILD:-1}
26
27# Automatically determine the architecture we're building on:
28if [ -z "$ARCH" ]; then
29  case "$( uname -m )" in
30    i?86) export ARCH=i586 ;;
31    arm*) export ARCH=arm ;;
32    # Unless $ARCH is already set, use uname -m for all other archs:
33       *) export ARCH=$( uname -m ) ;;
34  esac
35fi
36
37NUMJOBS=${NUMJOBS:-" -j7 "}
38
39if [ "$ARCH" = "i586" ]; then
40  SLKCFLAGS="-O2 -m32 -march=i586 -mtune=i686"
41elif [ "$ARCH" = "s390" ]; then
42  SLKCFLAGS="-O2"
43elif [ "$ARCH" = "x86_64" ]; then
44  SLKCFLAGS="-O2 -fPIC"
45else
46  SLKCFLAGS="-O2"
47fi
48
49CWD=$(pwd)
50TMP=${TMP:-/tmp}
51PKG=$TMP/package-$PKGNAM
52
53rm -rf $PKG
54mkdir -p $TMP $PKG
55
56cd $TMP
57rm -rf $PKGNAM-$VERSION
58tar xvf $CWD/$PKGNAM-$VERSION.tar.?z* || exit 1
59cd $PKGNAM-$VERSION
60
61chown -R root:root .
62find . \
63  \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
64  -exec chmod 755 {} \; -o \
65  \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
66  -exec chmod 644 {} \;
67
68mkdir cmake-build
69cd cmake-build
70../bootstrap \
71  --prefix=/usr \
72  --docdir=/doc/$PKGNAM-$VERSION \
73  --system-curl \
74  --system-expat \
75  --no-system-jsoncpp \
76  --system-zlib \
77  --system-bzip2 \
78  --system-libarchive || exit 1
79#  --system-libs
80#  --sphinx-man \
81
82
83# Build
84CFLAGS="$SLKCFLAGS" \
85CXXFLAGS="$SLKCFLAGS" \
86  ../configure \
87  --prefix=/usr \
88  --docdir=/doc/$PKGNAM-$VERSION \
89  --system-curl \
90  --system-expat \
91  --no-system-jsoncpp \
92  --system-zlib \
93  --system-bzip2 \
94  --system-libarchive \
95  --build=$ARCH-slackware-linux
96#  --system-libs \
97#  --sphinx-man \
98
99
100make $NUMJOBS || make || exit 1
101make install DESTDIR=$PKG || exit 1
102
103# Install preprocessed man pages instead of adding six new python packages:
104( cd $PKG
105  tar xf $CWD/cmake.manpages.tar.xz
106)
107
108# If there's a ChangeLog, installing at least part of the recent history
109# is useful, but don't let it get totally out of control:
110if [ -r ../ChangeLog.txt ]; then
111  DOCSDIR=$(echo $PKG/usr/doc/${PKGNAM}-$VERSION)
112  cat ../ChangeLog.txt | head -n 1000 > $DOCSDIR/ChangeLog.txt
113  touch -r ../ChangeLog.txt $DOCSDIR/ChangeLog.txt
114fi
115
116# How many redundant docs do we need?
117# If you really require the docbook, it is in the source.
118rm -f $PKG/usr/doc/$PKGNAM-$VERSION/*.docbook
119
120# Compress and link manpages, if any:
121if [ -d $PKG/usr/man ]; then
122  ( cd $PKG/usr/man
123    for manpagedir in $(find . -type d -name "man*") ; do
124      ( cd $manpagedir
125        for eachpage in $( find . -type l -maxdepth 1) ; do
126          ln -s $( readlink $eachpage ).gz $eachpage.gz
127          rm $eachpage
128        done
129        gzip -9 *.?
130      )
131    done
132  )
133fi
134
135find $PKG | xargs file | grep -e "executable" -e "shared object" \
136  | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
137
138mkdir -p $PKG/install
139cat $CWD/slack-desc > $PKG/install/slack-desc
140
141cd $PKG
142/sbin/makepkg -l y -c n $TMP/$PKGNAM-$VERSION-$ARCH-$BUILD.txz
143
Note: See TracBrowser for help on using the repository browser.