source: npl/overig/curl/curl.SlackBuild.orig @ c5c522c

gcc484ntopperl-5.22
Last change on this file since c5c522c was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 4.2 KB
RevLine 
[c5c522c]1#!/bin/sh
2
3# Copyright 2008, 2009, 2010, 2011, 2013, 2014, 2016  Patrick J. Volkerding, Sebeka, MN, USA
4# All rights reserved.
5#
6# Redistribution and use of this script, with or without modification, is
7# permitted provided that the following conditions are met:
8#
9# 1. Redistributions of this script must retain the above copyright
10#    notice, this list of conditions and the following disclaimer.
11#
12#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
13#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
14#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
15#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
16#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
17#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
18#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
19#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
20#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
21#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
22
23
24PKGNAM=curl
25VERSION=${VERSION:-$(echo curl-*.tar.bz2 | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
26BUILD=${BUILD:-1}
27
28# Automatically determine the architecture we're building on:
29if [ -z "$ARCH" ]; then
30  case "$( uname -m )" in
31    i?86) export ARCH=i586 ;;
32    arm*) export ARCH=arm ;;
33    # Unless $ARCH is already set, use uname -m for all other archs:
34       *) export ARCH=$( uname -m ) ;;
35  esac
36fi
37
38NUMJOBS=${NUMJOBS:-" -j7 "}
39
40CWD=$(pwd)
41TMP=${TMP:-/tmp}
42PKG=$TMP/package-curl
43
44# Uncomment to build a no-SSL version:
45#SSLOPT=--without-ssl
46
47if [ "$ARCH" = "i586" ]; then
48  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
49  LIBDIRSUFFIX=""
50elif [ "$ARCH" = "s390" ]; then
51  SLKCFLAGS="-O2"
52  LIBDIRSUFFIX=""
53elif [ "$ARCH" = "x86_64" ]; then
54  SLKCFLAGS="-O2 -fPIC"
55  LIBDIRSUFFIX="64"
56else
57  SLKCFLAGS="-O2"
58  LIBDIRSUFFIX=""
59fi
60
61rm -rf $PKG
62mkdir -p $PKG
63cd $TMP
64rm -rf curl-$VERSION
65tar xvf $CWD/curl-$VERSION.tar.bz2 || exit 1
66cd curl-$VERSION
67
68chown -R root:root .
69find . \
70  \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
71  -exec chmod 755 {} \; -o \
72  \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
73  -exec chmod 644 {} \;
74
75CFLAGS="$SLKCFLAGS" \
76./configure \
77  --prefix=/usr \
78  --libdir=/usr/lib${LIBDIRSUFFIX} \
79  --mandir=/usr/man \
80  --with-ca-bundle=/usr/share/curl/ca-bundle.crt \
81  --enable-static=no \
82  $SSLOPT
83
84make $NUMJOBS || make || exit 1
85make install DESTDIR=$PKG || exit 1
86
87mkdir -p $PKG/usr/share/curl
88cp -a $CWD/cacert.pem.bz2 $PKG/usr/share/curl
89( cd $PKG/usr/share/curl
90  bzip2 -d cacert.pem.bz2
91  mv cacert.pem ca-bundle.crt
92  chown root:root ca-bundle.crt
93  chmod 644 ca-bundle.crt
94)
95
96# We don't ship the related perl script (yet):
97rm -f $PKG/usr/man/man1/mk-ca-bundle.1
98
99find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
100  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
101
102#strip -g $PKG/usr/lib${LIBDIRSUFFIX}/libcurl.a
103
104mkdir -p $PKG/usr/doc/curl-$VERSION
105cp -a \
106  COPYING* README* \
107  $PKG/usr/doc/curl-$VERSION
108( cd docs
109  rm -rf Makefile* curl-config.1 curl-config.html curl.1 curl.html libcurl
110  cp -a \
111    BUGS  FAQ FEATURES INSTALL  MANUAL README* RESOURCES THANKS TODO examples \
112    $PKG/usr/doc/curl-$VERSION )
113# Get rid of .deps cruft:
114rm -rf $PKG/usr/doc/curl-$VERSION/examples/.deps
115
116# If there's a CHANGES file, installing at least part of the recent history
117# is useful, but don't let it get totally out of control:
118if [ -r CHANGES ]; then
119  DOCSDIR=$(echo $PKG/usr/doc/${PKGNAM}-$VERSION)
120  cat CHANGES | head -n 1000 > $DOCSDIR/ChangeLog
121  touch -r CHANGES $DOCSDIR/ChangeLog
122fi
123
124# Compress and if needed symlink the man pages:
125if [ -d $PKG/usr/man ]; then
126  ( cd $PKG/usr/man
127    for manpagedir in $(find . -type d -name "man*") ; do
128      ( cd $manpagedir
129        for eachpage in $( find . -type l -maxdepth 1) ; do
130          ln -s $( readlink $eachpage ).gz $eachpage.gz
131          rm $eachpage
132        done
133        gzip -9 *.?
134      )
135    done
136  )
137fi
138
139mkdir -p $PKG/install
140cat $CWD/slack-desc > $PKG/install/slack-desc
141
142cd $PKG
143/sbin/makepkg -l y -c n $TMP/curl-$VERSION-$ARCH-$BUILD.txz
144
Note: See TracBrowser for help on using the repository browser.