source: npl/overig/doxygen/doxygen.SlackBuild.orig @ c5c522c

gcc484ntopperl-5.22
Last change on this file since c5c522c was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 3.7 KB
Line 
1#!/bin/sh
2
3# Copyright 2008, 2009, 2010  Patrick J. Volkerding, Sebeka, MN, USA
4# All rights reserved.
5#
6# Redistribution and use of this script, with or without modification, is
7# permitted provided that the following conditions are met:
8#
9# 1. Redistributions of this script must retain the above copyright
10#    notice, this list of conditions and the following disclaimer.
11#
12#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
13#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
14#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
15#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
16#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
17#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
18#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
19#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
20#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
21#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
22
23
24VERSION=${VERSION:-$(basename $(echo doxygen-*.tar.?z* | rev | cut -f 3- -d . | cut -f 1 -d - | rev) .src)}
25BUILD=${BUILD:-1}
26
27NUMJOBS=${NUMJOBS:-" -j7 "}
28
29# Automatically determine the architecture we're building on:
30if [ -z "$ARCH" ]; then
31  case "$( uname -m )" in
32    i?86) export ARCH=i486 ;;
33    arm*) export ARCH=arm ;;
34    # Unless $ARCH is already set, use uname -m for all other archs:
35       *) export ARCH=$( uname -m ) ;;
36  esac
37fi
38
39if [ "$ARCH" = "i486" ]; then
40  SLKCFLAGS="-O2 -march=i486 -mtune=i686"
41  LIBDIRSUFFIX=""
42elif [ "$ARCH" = "i686" ]; then
43  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
44  LIBDIRSUFFIX=""
45elif [ "$ARCH" = "x86_64" ]; then
46  SLKCFLAGS="-O2 -fPIC"
47  LIBDIRSUFFIX="64"
48else
49  SLKCFLAGS="-O2"
50  LIBDIRSUFFIX=""
51fi
52
53CWD=$(pwd)
54TMP=${TMP:-/tmp}
55PKG=$TMP/package-doxygen
56
57rm -rf $PKG
58mkdir -p $TMP $PKG
59cd $TMP
60rm -rf doxygen-$VERSION
61tar xvf $CWD/doxygen-${VERSION}.src.tar.?z* || exit 1
62cd doxygen-$VERSION
63chown -R root:root .
64find . \
65  \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
66  -exec chmod 755 {} \; -o \
67  \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
68  -exec chmod 644 {} \;
69
70CFLAGS="$SLKCFLAGS" \
71CXXFLAGS="$SLKCFLAGS" \
72./configure \
73  --shared \
74  --release \
75  --prefix /usr \
76  --docdir /usr/doc/doxygen-$VERSION
77
78make $NUMJOBS || make || exit 1
79make install INSTALL=$PKG/usr DOCDIR=$PKG/usr/doc/doxygen-$VERSION
80#make install_docs INSTALL=$PKG/usr DOCDIR=$PKG/usr/doc/doxygen-$VERSION
81
82find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
83  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
84
85# If there are misplaced man pages, fix that:
86#mv $PKG/usr/*.1 $PKG/usr/man/man1
87
88# Compress and if needed symlink the man pages:
89if [ -d $PKG/usr/man ]; then
90  ( cd $PKG/usr/man
91    for manpagedir in $(find . -type d -name "man*") ; do
92      ( cd $manpagedir
93        for eachpage in $( find . -type l -maxdepth 1) ; do
94          ln -s $( readlink $eachpage ).gz $eachpage.gz
95          rm $eachpage
96        done
97        gzip -9 *.?
98      )
99    done
100  )
101fi
102
103mkdir -p $PKG/usr/doc/doxygen-$VERSION
104cp -a \
105  INSTALL LANGUAGE.HOWTO LICENSE PLATFORMS README* VERSION \
106  $PKG/usr/doc/doxygen-$VERSION
107
108# If there's a ChangeLog, installing at least part of the recent history
109# is useful, but don't let it get totally out of control:
110if [ -r ChangeLog ]; then
111  DOCSDIR=$(echo $PKG/usr/doc/*-$VERSION)
112  cat ChangeLog | head -n 1000 > $DOCSDIR/ChangeLog
113  touch -r ChangeLog $DOCSDIR/ChangeLog
114fi
115
116mkdir -p $PKG/install
117cat $CWD/slack-desc > $PKG/install/slack-desc
118
119cd $PKG
120/sbin/makepkg -l y -c n $TMP/doxygen-$VERSION-$ARCH-$BUILD.txz
121
Note: See TracBrowser for help on using the repository browser.