source: npl/overig/drbd_utils/drbd_utils.SlackBuild @ 26ffad7

Last change on this file since 26ffad7 was 929bb42, checked in by Edwin Eefting <edwin@datux.nl>, 3 years ago

trying kernel 5.14

  • Property mode set to 100755
File size: 2.2 KB
Line 
1#!/bin/bash
2##NEED:git
3##DEP:linux
4##DEP:linux_src
5##DEP:linux_headers
6#NEED:libxslt
7#NEED:linuxdoc_tools
8##NEED:docbook
9##NEED:udev
10
11#######Essential package info.
12#Change these if autodetection fails.
13
14#Name of the Syn-3 package that we are going to create
15NAME=`basename $0|sed 's/.SlackBuild//'`
16
17#Archive of the sourcefiles to unpack
18SRC_ARC=`ls *.tar.* *.zip 2>/dev/null`
19
20#Version of the sourcefiles
21VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g' | sed 's/\.zip$//g'`
22
23#Architecture that the created binaries run on.
24#Use noarch for scripts.
25ARCH=`uname -m`
26
27#from this point on, exit on errors:
28set -e
29
30########Build and create the pacakge.
31#Uncomment the stuff that you dont want or need
32
33#Unpack source
34#(uncomment if not needed)
35syn3_unpack $SRC_ARC
36
37#Directory where the sourcefiles are unpacked.
38#(you might have to adjust this if autodetection fails)
39SRC_DIR=`ls -c|head -1`
40
41#apply patches
42#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
43
44pushd $SRC_DIR
45
46#AUTOMAKE: Configure
47#Some usefull stuff you sometimes need to set:
48#export LDFLAGS="-L/usr/X11/lib/ -L/usr/lib/mysql/"
49#export LD_LIBRARY_PATH=/usr/lib/mysql
50#export VPATH=$LD_LIBRARY_PATH
51#export CFLAGS="-std=c89"
52#export CFLAGS="-fgnu89-inline" #If "multiple definition of `foo'" Also see http://gcc.gnu.org/gcc-4.3/porting_to.html
53MAKE_OPTS=""
54./configure --prefix=/usr --sysconfdir=/etc --sbindir=/sbin  --without-manual || exit 1
55
56#AUTOMAKE: Compile
57make $MAKE_OPTS || exit 1
58
59#AUTOMAKE: Test (optional)
60if grep ^test: Makefile; then
61        make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1
62        make $MAKE_OPTS test || exit 1
63elif grep ^check: Makefile; then
64        make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1
65        make $MAKE_OPTS check || exit 1
66fi
67
68#AUTOMAKE: Install
69mkdir -p /tmp/pkg &>/dev/null
70make pkgconfigdir=/usr/lib/pkgconfig install_prefix=/tmp/pkg DESTDIR=/tmp/pkg INSTALL_ROOT=/tmp/pkg install_root=/tmp/pkg $MAKE_OPTS install || exit 1
71popd
72
73#strip bins and other stuff
74syn3_strip /tmp/pkg || exit 1
75
76#move development stuff and create seperate development package
77syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
78syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
79
80#make main package
81syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
82
83
84
Note: See TracBrowser for help on using the repository browser.