source: npl/overig/duplicity/duplicity.SlackBuild @ 30f002a

Last change on this file since 30f002a was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 1.4 KB
Line 
1#!/bin/bash
2# Generic python build script. (C)DatuX
3# Put in in a builddirectory with a python tarfile that contains a setup.py.
4# Please python_modulename for python modules.
5
6#DEP:python
7#DEP:python_setuptools
8#DEP:librsync
9#DEP:gnupg
10#DEP:python_paramiko
11#DEP:python_pycryptopp
12#DEP:ncftp
13
14
15#######Essential package info.
16#Change these if autodetection fails.
17
18#Name of the Syn-3 package that we are going to create
19NAME=`basename $0|sed 's/.SlackBuild//'`
20
21
22#Archive of the sourcefiles to unpack
23SRC_ARC=`ls *.tar.*`
24
25#Version of the sourcefiles
26VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g'`
27
28#Directory of the sourcefiles to build (after optional unpacking)
29SRC_DIR=`echo $SRC_ARC| sed 's/\.tar\..*$//g'`
30
31#Architecture that the created binaries run on.
32#Use noarch for scripts.
33ARCH=`uname -m`
34
35
36########Build and create the pacakge.
37#Uncomment the stuff that you dont want or need
38
39#Unpack source
40#(uncomment if not needed)
41syn3_unpack $SRC_ARC || exit 1
42
43#apply patches
44#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
45
46pushd $SRC_DIR || exit 1
47python setup.py install --root=/tmp/pkg || exit 1
48popd
49
50#strip bins and other stuff
51syn3_strip /tmp/pkg || exit 1
52
53#move development stuff and create seperate development package
54syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
55syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
56
57#make main package
58syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
59
60
Note: See TracBrowser for help on using the repository browser.