[c5c522c] | 1 | #!/bin/sh |
---|
| 2 | |
---|
| 3 | # Copyright 2008, 2009, 2010, 2011, 2013 Patrick J. Volkerding, Sebeka, Minnesota, USA |
---|
| 4 | # All rights reserved. |
---|
| 5 | # |
---|
| 6 | # Redistribution and use of this script, with or without modification, is |
---|
| 7 | # permitted provided that the following conditions are met: |
---|
| 8 | # |
---|
| 9 | # 1. Redistributions of this script must retain the above copyright |
---|
| 10 | # notice, this list of conditions and the following disclaimer. |
---|
| 11 | # |
---|
| 12 | # THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED |
---|
| 13 | # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF |
---|
| 14 | # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO |
---|
| 15 | # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, |
---|
| 16 | # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, |
---|
| 17 | # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; |
---|
| 18 | # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, |
---|
| 19 | # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR |
---|
| 20 | # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF |
---|
| 21 | # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. |
---|
| 22 | |
---|
| 23 | PKGNAM=expat |
---|
| 24 | VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z* | rev | cut -f 3- -d . | cut -f 1 -d - | rev)} |
---|
| 25 | BUILD=${BUILD:-1} |
---|
| 26 | |
---|
| 27 | # Automatically determine the architecture we're building on: |
---|
| 28 | if [ -z "$ARCH" ]; then |
---|
| 29 | case "$( uname -m )" in |
---|
| 30 | i?86) export ARCH=i486 ;; |
---|
| 31 | arm*) export ARCH=arm ;; |
---|
| 32 | # Unless $ARCH is already set, use uname -m for all other archs: |
---|
| 33 | *) export ARCH=$( uname -m ) ;; |
---|
| 34 | esac |
---|
| 35 | fi |
---|
| 36 | |
---|
| 37 | if [ "$ARCH" = "i486" ]; then |
---|
| 38 | SLKCFLAGS="-O2 -march=i486 -mtune=i686" |
---|
| 39 | LIBDIRSUFFIX="" |
---|
| 40 | elif [ "$ARCH" = "s390" ]; then |
---|
| 41 | SLKCFLAGS="-O2" |
---|
| 42 | LIBDIRSUFFIX="" |
---|
| 43 | elif [ "$ARCH" = "x86_64" ]; then |
---|
| 44 | SLKCFLAGS="-O2 -fPIC" |
---|
| 45 | LIBDIRSUFFIX="64" |
---|
| 46 | else |
---|
| 47 | SLKCFLAGS="-O2" |
---|
| 48 | LIBDIRSUFFIX="" |
---|
| 49 | fi |
---|
| 50 | |
---|
| 51 | CWD=$(pwd) |
---|
| 52 | TMP=${TMP:-/tmp} |
---|
| 53 | PKG=$TMP/package-expat |
---|
| 54 | |
---|
| 55 | rm -rf $PKG |
---|
| 56 | mkdir -p $TMP $PKG |
---|
| 57 | cd $TMP |
---|
| 58 | rm -rf expat-$VERSION |
---|
| 59 | tar xvf $CWD/expat-$VERSION.tar.?z* || exit 1 |
---|
| 60 | cd expat-$VERSION |
---|
| 61 | |
---|
| 62 | chown -R root:root . |
---|
| 63 | find . -perm 777 -exec chmod 755 {} \; |
---|
| 64 | find . -perm 664 -exec chmod 644 {} \; |
---|
| 65 | CFLAGS="$SLKCFLAGS" \ |
---|
| 66 | ./configure \ |
---|
| 67 | --prefix=/usr \ |
---|
| 68 | --libdir=/usr/lib${LIBDIRSUFFIX} \ |
---|
| 69 | --mandir=/usr/man \ |
---|
| 70 | --build=$ARCH-slackware-linux |
---|
| 71 | make -j4 || exit 1 |
---|
| 72 | make install DESTDIR=$PKG |
---|
| 73 | ( cd $PKG |
---|
| 74 | find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null |
---|
| 75 | find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null |
---|
| 76 | ) |
---|
| 77 | mkdir -p $PKG/usr/doc/expat-$VERSION |
---|
| 78 | cp -a \ |
---|
| 79 | COPYING* Changes README* doc/reference.html \ |
---|
| 80 | $PKG/usr/doc/expat-$VERSION |
---|
| 81 | gzip -9 $PKG/usr/man/man?/*.? |
---|
| 82 | mkdir -p $PKG/install |
---|
| 83 | cat $CWD/slack-desc > $PKG/install/slack-desc |
---|
| 84 | |
---|
| 85 | cd $PKG |
---|
| 86 | makepkg -l y -c n $TMP/expat-$VERSION-$ARCH-$BUILD.txz |
---|
| 87 | |
---|