source: npl/overig/gd/gd.SlackBuild.orig @ 105afb5

Last change on this file since 105afb5 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 3.4 KB
Line 
1#!/bin/sh
2
3# Copyright 2006, 2007, 2008, 2009, 2010, 2016  Patrick J. Volkerding, Sebeka, MN, USA
4# All rights reserved.
5#
6# Redistribution and use of this script, with or without modification, is
7# permitted provided that the following conditions are met:
8#
9# 1. Redistributions of this script must retain the above copyright
10#    notice, this list of conditions and the following disclaimer.
11#
12#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
13#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
14#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
15#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
16#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
17#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
18#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
19#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
20#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
21#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
22
23
24PKGNAM=gd
25VERSION=${VERSION:-$(echo libgd-*.tar.xz | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
26BUILD=${BUILD:-1}
27
28# Automatically determine the architecture we're building on:
29if [ -z "$ARCH" ]; then
30  case "$( uname -m )" in
31    i?86) export ARCH=i586 ;;
32    arm*) export ARCH=arm ;;
33    # Unless $ARCH is already set, use uname -m for all other archs:
34       *) export ARCH=$( uname -m ) ;;
35  esac
36fi
37
38NUMJOBS=${NUMJOBS:-" -j7 "}
39
40CWD=$(pwd)
41TMP=${TMP:-/tmp}
42PKG=$TMP/package-${PKGNAM}
43
44rm -rf $PKG
45mkdir -p $TMP $PKG
46
47if [ "$ARCH" = "i586" ]; then
48  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
49  LIBDIRSUFFIX=""
50elif [ "$ARCH" = "s390" ]; then
51  SLKCFLAGS="-O2"
52  LIBDIRSUFFIX=""
53elif [ "$ARCH" = "x86_64" ]; then
54  SLKCFLAGS="-O2 -fPIC"
55  LIBDIRSUFFIX="64"
56else
57  SLKCFLAGS="-O2"
58  LIBDIRSUFFIX=""
59fi
60
61cd $TMP
62rm -rf libgd-${VERSION}
63tar xvf $CWD/libgd-$VERSION.tar.xz || exit 1
64cd libgd-$VERSION || exit 1
65
66# Make sure ownerships and permissions are sane:
67chown -R root:root .
68find . \
69  \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
70  -exec chmod 755 {} \; -o \
71  \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
72  -exec chmod 644 {} \;
73
74./bootstrap.sh
75
76# Configure:
77CFLAGS="$SLKCFLAGS" \
78./configure \
79  --prefix=/usr \
80  --libdir=/usr/lib${LIBDIRSUFFIX} \
81  --disable-static \
82  --program-prefix= \
83  --program-suffix= \
84  --build=$ARCH-slackware-linux
85
86# Build and install:
87make $NUMJOBS || make || exit 1
88make install DESTDIR=$PKG || exit 1
89
90# Strip binaries:
91find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
92  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
93
94# Compress and link manpages, if any:
95if [ -d $PKG/usr/man ]; then
96  ( cd $PKG/usr/man
97    for manpagedir in $(find . -type d -name "man*") ; do
98      ( cd $manpagedir
99        for eachpage in $( find . -type l -maxdepth 1) ; do
100          ln -s $( readlink $eachpage ).gz $eachpage.gz
101          rm $eachpage
102        done
103        gzip -9 *.?
104      )
105    done
106  )
107fi
108
109# Add a documentation directory:
110mkdir -p $PKG/usr/doc/${PKGNAM}-$VERSION
111cp -a \
112  COPYING  \
113  $PKG/usr/doc/${PKGNAM}-$VERSION
114# Fix stupid permissions:
115chmod 644 $PKG/usr/doc/${PKGNAM}-$VERSION/*
116
117mkdir -p $PKG/install
118cat $CWD/slack-desc > $PKG/install/slack-desc
119
120cd $TMP/package-${PKGNAM}
121/sbin/makepkg -l y -c n $TMP/${PKGNAM}-$VERSION-$ARCH-$BUILD.txz
122
Note: See TracBrowser for help on using the repository browser.