source: npl/overig/gnutls/gnutls.SlackBuild.orig

Last change on this file was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 3.8 KB
Line 
1#!/bin/sh
2
3# Copyright 2007, 2008, 2009, 2010, 2016  Patrick Volkerding, Sebeka, MN, USA
4# All rights reserved.
5#
6# Redistribution and use of this script, with or without modification, is
7# permitted provided that the following conditions are met:
8#
9# 1. Redistributions of this script must retain the above copyright
10#    notice, this list of conditions and the following disclaimer.
11#
12# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
13# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
14# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
15# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
16# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
17# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
18# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
19# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
20# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
21# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
22
23
24PKGNAM=gnutls
25VERSION=${VERSION:-$(echo gnutls-*.tar.xz | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
26BUILD=${BUILD:-1}
27
28# Automatically determine the architecture we're building on:
29if [ -z "$ARCH" ]; then
30  case "$( uname -m )" in
31    i?86) export ARCH=i586 ;;
32    arm*) export ARCH=arm ;;
33    # Unless $ARCH is already set, use uname -m for all other archs:
34       *) export ARCH=$( uname -m ) ;;
35  esac
36fi
37
38NUMJOBS=${NUMJOBS:-" -j7 "}
39
40if [ "$ARCH" = "i586" ]; then
41  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
42  LIBDIRSUFFIX=""
43elif [ "$ARCH" = "s390" ]; then
44  SLKCFLAGS="-O2"
45  LIBDIRSUFFIX=""
46elif [ "$ARCH" = "x86_64" ]; then
47  SLKCFLAGS="-O2 -fPIC"
48  LIBDIRSUFFIX="64"
49else
50  SLKCFLAGS="-O2"
51  LIBDIRSUFFIX=""
52fi
53
54CWD=$(pwd)
55TMP=${TMP:-/tmp}
56PKG=$TMP/package-$PKGNAM
57rm -rf $PKG
58mkdir -p $TMP $PKG
59
60cd $TMP
61
62rm -rf $PKGNAM-$VERSION
63tar xvf $CWD/$PKGNAM-$VERSION.tar.xz || exit 1
64cd $PKGNAM-$VERSION || exit 1
65
66chown -R root:root .
67find . \
68  \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
69  -exec chmod 755 {} \; -o \
70  \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
71  -exec chmod 644 {} \;
72
73CFLAGS="$SLKCFLAGS" \
74CXXFLAGS="$SLKCFLAGS" \
75./configure \
76  --prefix=/usr \
77  --libdir=/usr/lib${LIBDIRSUFFIX} \
78  --sysconfdir=/etc \
79  --localstatedir=/var \
80  --infodir=/usr/info \
81  --mandir=/usr/man \
82  --enable-static=no \
83  --disable-rpath \
84  --with-included-libtasn1 \
85  --enable-openssl-compatibility \
86  --build=$ARCH-slackware-linux \
87  --host=$ARCH-slackware-linux
88
89make $NUMJOBS || make || exit 1
90make install DESTDIR=$PKG || exit 1
91
92find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
93  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
94
95# Compress and link manpages, if any:
96if [ -d $PKG/usr/man ]; then
97  ( cd $PKG/usr/man
98    for manpagedir in $(find . -type d -name "man*") ; do
99      ( cd $manpagedir
100        for eachpage in $( find . -type l -maxdepth 1) ; do
101          ln -s $( readlink $eachpage ).gz $eachpage.gz
102          rm $eachpage
103        done
104        gzip -9 *.?
105      )
106    done
107  )
108fi
109
110( cd $PKG/usr/info
111  rm -f dir
112  gzip -9 *.info*
113)
114
115mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
116cp -a \
117  AUTHORS COPYING* INSTALL NEWS README* THANKS \
118  $PKG/usr/doc/$PKGNAM-$VERSION
119
120# If there's a ChangeLog, installing at least part of the recent history
121# is useful, but don't let it get totally out of control:
122if [ -r ChangeLog ]; then
123  DOCSDIR=$(echo $PKG/usr/doc/${PKGNAM}-$VERSION)
124  cat ChangeLog | head -n 1000 > $DOCSDIR/ChangeLog
125  touch -r ChangeLog $DOCSDIR/ChangeLog
126fi
127
128mkdir -p $PKG/install
129cat $CWD/slack-desc > $PKG/install/slack-desc
130
131cd $PKG
132/sbin/makepkg -l y -c n -p $TMP/$PKGNAM-$VERSION-$ARCH-$BUILD.txz
133
Note: See TracBrowser for help on using the repository browser.